Try our conversational search powered by Generative AI!

Moving website to another server


I'm having quite a difficult problem moving my site. I was developing on a dedicated cloud server which used sql v10.5, and I'm trying to copy my website to my local server which is running sql v10.0. I have tried the following with no luck.

Backup database, try to restore. Failed with error stating backups from newer versions cannot be restored to an older sql version

Export/Import data wizard. This doesn't copy keys over, and only copies data. Site wouldn't load due to missing stored procedures/views/schemas, etc.

Generate Scripts: This gave me the most functionality, my front end was fully functional, although the CMS would not display anything. I would get an error stating there is no definition for dbType String in tblBigList (may not be exact table name, I'm going by memory).


What is the best method for moving a site to an older server? My IIS and server config is the same, it's just a bit older of a db.

Aug 27, 2012 20:27

I forgot to mention I also installed a blank database and then tried to use episerver's export feature. This worked for everything thus far except the actual page content which it doesn't do anything with.

Aug 27, 2012 20:48

Hi Ben,

Well I guess upgrading your local machine would be the easiest but guessing that might not be possible.

Did you try installing a blank database and then use the Export/Import data wizard? That should give you the SP's Views and schemas you need.

Aug 28, 2012 9:17

Upgrading isn't really an option as the server is hosted through another company and it's fairly locked down as far as upgrading goes. I have tried using a blank database and the export wizard, however this would always give me errors and never complete properly.. The closest I've gotten is by using the generate scripts functionality.. I just ran it again and this is the exact error message I'm getting when I go to edit mode:

Could not map property LanguageBranch - table tblBigTable does not contain any columns that map to DbType.String

If I install a blank database I don't get this error and I'm able to create pages, it's just that all my data isn't present. One thing I will point out is immediately after the script generated, I was able to see my pages in the neft nav, but when I tried to expand the tree, I got a javascript alert with a cryptic error, then after a refresh I'm getting the error above.

From what I've read this is a fairly straightforward process, I'm not sure what exactly I'm doing wrong here.

Aug 28, 2012 15:51

this is the error message I'm getting in an alert box when I expand the tree to view pages

Error: The target 'FullRegion$explorerTreeView$treeView' for the callback could not be found or did not implement ICallbackEventHandler.

Aug 28, 2012 18:48


In the event anyone else is having this problem, I fixed it by doing the following:

change .NET version in IIS to 2.0 (was set to 4.0 by default. I read epi does now support 4.0 but my app was built using 2.0)

when building generate scripts, I changed the target to 2005 server (even though I'm running 2008 server) and it transfered everything just fine.

Aug 28, 2012 19:54

I had exactly the same issue. I used your tip when generating the script to target a specific SQL version. What worked for me was targetting one version older. not the current as that did not work. Thank you!

Mar 14, 2017 1:40
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.