SaaS CMS has officially launched! Learn more now.

Community on Win2003 SP2 / IIS6


Im having problems installing an Epi 5R2SP2 + Community 3.2.517.24 on two different Win2003 servers.

The site works fine on my Vista/IIS7 development laptop but when installed on the server I can't login.

This is what I get when I try to login
[NullReferenceException: Object reference not set to an instance of an object.]
EPiServer.Common.Settings.get_DefaultSecurity() +12
EPiServer.Common.Web.Authorization.MembershipProvider.GetUser(String username, Boolean userIsOnline) +15
EPiServer.Security.MultiplexingMembershipProvider.FindMembershipUser(String username) +111
EPiServer.Security.MultiplexingMembershipProvider.get_CurrentMembershipUser() +77
EPiServer.Security.MultiplexingMembershipProvider.get_CurrentProvider() +73
EPiServer.Security.MultiplexingMembershipProvider.ValidateUser(String username, String password) +26

Here's my role/membership config:

Is there a known problem on Win2003/IIS6?
Aug 19, 2009 16:18

Ooops, lost in translation :)

<roleManager enabled="true" defaultProvider="MultiplexingRoleProvider" cacheRolesInCookie="true">
<add name="MultiplexingRoleProvider" type="EPiServer.Security.MultiplexingRoleProvider, EPiServer" provider1="EPiServerCommonRoleProvider" provider2="SqlServerRoleProvider" providerMap1="EPiServerCommonMembershipProvider" providerMap2="SqlServerMembershipProvider"/>
<add name="SqlServerRoleProvider" applicationName="EPiServerSample" connectionStringName="EPiServerDB" type="System.Web.Security.SqlRoleProvider, System.Web, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
<add name="EPiServerCommonRoleProvider" applicationName="EPiServerSample" type="EPiServer.Common.Web.Authorization.RoleProvider, EPiServer.Common.Web.Authorization"/>
<membership defaultProvider="MultiplexingMembershipProvider" userIsOnlineTimeWindow="10">
<add name="MultiplexingMembershipProvider" type="EPiServer.Common.Web.Authorization.Multiplexing.IntegrationMultiplexingMembershipProvider, EPiServer.Common.Web.Authorization.Multiplexing" provider1="EPiServerCommonMembershipProvider" provider2="SqlServerMembershipProvider" roleToSynchronize1="*" />
<add name="SqlServerMembershipProvider" type="System.Web.Security.SqlMembershipProvider, System.Web, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" connectionStringName="EPiServerDB" requiresQuestionAndAnswer="false" applicationName="EPiServerSample" requiresUniqueEmail="true" passwordFormat="Hashed" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="7" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" passwordStrengthRegularExpression=""/>
<add name="EPiServerCommonMembershipProvider" applicationName="EPiServerCommonApplication" type="EPiServer.Common.Web.Authorization.MembershipProvider, EPiServer.Common.Web.Authorization"/>

Aug 19, 2009 16:19

It should work on IIS6.

Can you check your event log to see whether there were any errors during startup?

Aug 20, 2009 11:25
Nops, nothing suspicious in the error log or the event log. The site runs just fine until I try to login to /edit or /admin. Changing to the SQL-provider instead of multiplexing works fine but using the EPiCommon alone gives the same error.
Aug 20, 2009 11:39
Is this a standalone community install or Relate+?
Aug 21, 2009 13:42

It was a clean R2Sp1 that I upgraded to Sp2 and then installed a standalone community on using Deployment Center.



Aug 21, 2009 13:49

Do you get anything at all related to EPiServer Common/Community in the event log?

Like the "Starting Up..." and "Done Starting Up!" messages?


I would suggest you examine the http module list in web.config, among other things, "EPiServer.Common.Web.HttpModule, EPiServer.Common.Web" should be in there (you may want to compare the list between the working and non-working sites).


Aug 21, 2009 14:05

Ah, "Module 'EPiServerCommunity' successfully started!"

Some things where missing in system.webServer/modules but they did exist in system.web/httpModules.

Still not working 100% but im almost there. Thanks for you help.


Aug 25, 2009 10:41
This thread is locked and should be used for reference only. Please use the Legacy add-ons forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.