Try our conversational search powered by Generative AI!

Problems importing Composer Page Types


I'm getting this error when trying to import the Composer Page Types:

Number of page type definitions: 2
Page Type Name: [ExtensionSys] Composer wide page. Path: /composer/pages/pagewide.aspx
Error: The remote server returned an error: (404) Not Found.
The functions get imported without any problems.
I'm running Composer 4 with CMS 6
Oct 21, 2010 13:59


Could you verify the composer/pages/pagewide.aspx if it exists on the your website.
How do you import the page type? by using the EPiServer standard Import: Import Data or the Composers: EPiServer Composer - Import/Export?

Hieu Doan.

Oct 21, 2010 16:25

I'm using the Composer - Import/Export.

The pagewide.aspx exists, but I had a case of ambigous reference to it at one point, till i removed a dll (forgott the name, but composerTemplates something)..

Oct 21, 2010 18:01


We are experiencing the same problem. We can import the functions but when it comes to the page it returns the same error. The page does exist and can be found at the specified location and using the composer import/export function.

There is also a composer "enabled" page in the current structure and when we enable it under availabe page types of a page it doesnt show in the create process despite that we got the correct rights for it.

Frankly i find this a little bit strange since the upgrade from composer 3.2.5 to 4.0 worked like a charm, but when it comes to the import thingie there is a major flaw. We also noticed that there was a couple of things missing in the web.config after the installation which we were forced to add to make it work. I dont get why there isnt a guide or something just specifying which dlls i need to reg in the config pages this would make things much easier...

Well we really need some advice in how to get things working according to the episerver "imagined how it should work" guide to installing composer...


We tried the extension page and enabled composer on it. It worked after some adjustments both in masterpage and admin-mode settings. However the import still doesnt work and now returns error 500. Checked the path and everything but still dont work...

Edited, Apr 01, 2011 9:39
This thread is locked and should be used for reference only. Please use the Legacy add-ons forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.