Try our conversational search powered by Generative AI!

There must be at least one site configured for the application to start


After migration from Relate+ 1 to Relate+ 2 I'm having trouble getting the site up and running.
I assume it's a web.config related issue, however I've compared it to a clean installation of
Relate+ 2 but can't find the root to the problem. Any suggestions? 

My yellow screen of death:

Server Error in '/' Application.

There must be at least one site configured for the application to start.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Configuration.ConfigurationErrorsException: There must be at least one site configured for the application to start.

Source Error:

[No relevant source lines]

Source File: c:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\df51bec1\7a459c3b\App_global.asax.7nc5qile.0.cs Line: 0

Stack Trace:

[ConfigurationErrorsException: There must be at least one site configured for the application to start.]
   EPiServer.Community.Configuration.EPiServerCommunitySection.OnPostInit() +305
   EPiServer.Common.Configuration.ConfigurationSectionBase`1.GetInstance(String sectionName) +365
   EPiServer.Community.Configuration.EPiServerCommunitySection.get_Instance() +16
   EPiServer.Community.Search.SearchHandler.Initialize() +84
   EPiServer.Community.Search.SearchHandler..cctor() +86

[TypeInitializationException: The type initializer for 'EPiServer.Community.Search.SearchHandler' threw an exception.]
   EPiServer.Community.Search.SearchHandler.add_UpdatingIndex(UpdateIndexEventHandler value) +0
   EPiServer.Templates.RelatePlus.Templates.RelatePlus.InitializationModules.SearchHandlerModule.Initialize(InitializationEngine context) +56
   EPiServer.Framework.Initialization.InitializationEngine.InitializeModules() +337
   EPiServer.Framework.Initialization.InitializationEngine.Initialize(HostType hostType) +82
   EPiServer.Framework.Initialization.InitializationModule.StaticInitialization(HostType hostType) +154
   EPiServer.Framework.Initialization.InitializationModule.FrameworkInitialization(HostType hostType) +65
   EPiServer.Global..ctor() +54
   PTK.Web.Global..ctor() +29
   ASP.global_asax..ctor() in c:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\df51bec1\7a459c3b\App_global.asax.7nc5qile.0.cs:0

[TargetInvocationException: Exception has been thrown by the target of an invocation.]
   System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, Boolean& bNeedSecurityCheck) +0
   System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache) +86
   System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache) +230
   System.Activator.CreateInstance(Type type, Boolean nonPublic) +67
   System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) +1051
   System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) +111
   System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +215
   System.Web.HttpApplicationFactory.FireApplicationOnStart(HttpContext context) +8888824
   System.Web.HttpApplicationFactory.EnsureAppStartCalled(HttpContext context) +136
   System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context) +92
   System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +289
Jun 13, 2011 11:13

I know you solved this already, but in case anyone else encounters similar problems:

The sites have to be correctly configured in all of the following sections: episerver.framework, episerver.common, episerver.mail and/or The siteId:s must match.

Jun 13, 2011 13:38
Jun 13, 2011 13:41

Reusing this thread for the same issue. I get the same error on an CMS 6 R2 site. I have double checked that the siteIds matches between the config-files.

Nov 13, 2014 9:53
This thread is locked and should be used for reference only. Please use the Legacy add-ons forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.