Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Installation error, invalid object name tblPageType


I'm trying to install Episerver R2 on my workstation, but I get the following errormessage during the installation process :

Error - Invalid object name 'tblPageType'.


An unhandled error has occured:
Invalid object name 'tblPageType'.
When executing
At C:\Program Files\EPiServer\CMS\5.2.375.236\Install\System Scripts\Install Da
tabase (SqlServer).ps1:149 char:30
+ Set-EPiBuiltInPageTypePaths <<<<  -SqlServerName $wizard.Database.DatabaseS
erverName -SqlServerPort $wizard.Database.DatabaseServerPort -DatabaseName $wiz
ard.Database.DatabaseName -LoginName $wizard.Database.InstallerDatabaseLoginNam
e -LoginPassword $wizard.Database.InstallerDatabaseLoginPassword -UiPath "~$uiP
ath" -AvoidDbTransaction
An unhandled error has occured:Invalid object name 'tblPageType'.When executing
At C:\Program Files\EPiServer\CMS\5.2.375.236\Install\System Scripts\Install Database (SqlServer).ps1:149 char:30+ Set-EPiBuiltInPageTypePaths <<<<  -SqlServerName $wizard.Database.DatabaseServerName -SqlServerPort $wizard.Database.DatabaseServerPort -DatabaseName $wizard.Database.DatabaseName -LoginName $wizard.Database.InstallerDatabaseLoginName -LoginPassword $wizard.Database.InstallerDatabaseLoginPassword -UiPath "~$uiPath" -AvoidDbTransaction


I have an existing empty database that I'm trying to use.


Thanks for any tips on how to solve this.

Mar 15, 2010 13:16

I've started getting the same error. Windows Server 2008 R2 + SQL Server Enterprise 2008.

Apr 29, 2010 15:42

I raised a case with technical support and the official response I received was that the EPiServer Deployment Center has a minor bug in it that causes installation of the database to fail if you have already pre-created the database on your database server.

My quick solution was to remove the database I'd created but left the user and security I'd created in place, and then let the EPiServer Deployment Center recreate the database for me as part of the installation.

Hey presto, solved. Hopefully EPiServer will fix this bug soon.

Jun 02, 2010 11:18

Hi Rob, did you get a bug number from support? I am trying to look up the status of this bug..

Jun 02, 2010 13:00

Hi Per, I wasn't given one no, however you're welcome to the case number (192691) if that'll help you track down the right people to talk to internally.

Jun 02, 2010 13:04

Found it (22282), the behaviour was determined as "by design" and hence split into a fix and an feature request. The fix is already done and warns you when trying to install into an existing empty database and a feature request to support this scenario.

Jun 02, 2010 13:50
This thread is locked and should be used for reference only.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.