Try our conversational search powered by Generative AI!

Update 9 (7.6.3) causes script error in Edit mode


After I updated to 7.6.3, edit mode screams (or rather the console):

TypeError: Cannot read property 'label' of undefined
at _1f4.postscript (http://xyz/secure/ui/CMS/3.0.1097/ClientResources/epi-cms/widgets.js:2:58452)
at _199 (http://xyz/secure/ui/Shell/3.0.1209/ClientResources/dojo/dojo.js:15:39186)
at _1c5.postscript (http://xyz/secure/ui/CMS/3.0.1097/ClientResources/epi-cms/widgets.js:2:52808)
at new <anonymous> (http://xyz/secure/ui/Shell/3.0.1209/ClientResources/dojo/dojo.js:15:40990)
at _ec._createCommand (http://xyz/secure/ui/CMS/3.0.1097/ClientResources/epi-cms/widgets.js:2:26620)
at null.<anonymous> (http://xyz/secure/ui/CMS/3.0.1097/ClientResources/epi-cms/widgets.js:2:26523)
at Object._16e.forEach (http://xyz/secure/ui/Shell/3.0.1209/ClientResources/dojo/dojo.js:15:33034)
at null.<anonymous> (http://xyz/secure/ui/CMS/3.0.1097/ClientResources/epi-cms/widgets.js:2:26459)
at Object._16e.forEach (http://xyz/secure/ui/Shell/3.0.1209/ClientResources/dojo/dojo.js:15:33034)
at _ec._addCreateCommands (http://xyz/secure/ui/CMS/3.0.1097/ClientResources/epi-cms/widgets.js:2:26427)

I've seen a thread about something like this before ( but it didn't help me. Tried on two different sites, one is completely fresh.

Any ideas? Have I missed anything?

Mar 17, 2014 16:12

Hi André,

Did you get any errors while performing the upgrade (you don't happen to have the console manager output?)? I tried to repro this in a standard Alloy site with no success (depending how you see it).

Mar 17, 2014 17:49

No I didn't, expect some pink colored messages saying "folder is not empty, skipping"-like messages. Unless they are considered as errors? :)

It's on line 1907:

this.contextRootLabel = this.contextRootLabel || _1fa.contextualroot.label;

I then enabled debug mode in the clientResources-section of episerver.framework and extracted the "uncompressed.js" for the following files:

  • ClientResources\epi-cms\widgets.js
  • ClientResources\epi-cms\contenteditiing\_ContextualContentContextMixin.js

After that, the edit mode now loaded properly. There was one error message saying something about "The query is old". Sorry I couldn't post the whole message, since I clicked on another page and since then it hasn't reappeared.

Might there be something happening when the js-files are compressed maybe?

Edited, Mar 18, 2014 8:29
I have something similar:

TypeError: Cannot read property 'label' of undefined at _1f4.postscript (http://localhost:51873/EPiServer/CMS/3.0.1097/ClientResources/epi-cms/widgets.js:2:58452) at _199 (http://localhost:51873/EPiServer/Shell/3.0.1209/ClientResources/dojo/dojo.js:15:39186) at _1c5.postscript (http://localhost:51873/EPiServer/CMS/3.0.1097/ClientResources/epi-cms/widgets.js:2:52808) at new <anonymous> (http://localhost:51873/EPiServer/Shell/3.0.1209/ClientResources/dojo/dojo.js:15:40990) at _ec._createCommand (http://localhost:51873/EPiServer/CMS/3.0.1097/ClientResources/epi-cms/widgets.js:2:26620) at null.<anonymous> (http://localhost:51873/EPiServer/CMS/3.0.1097/ClientResources/epi-cms/widgets.js:2:26523) at Object._16e.forEach (http://localhost:51873/EPiServer/Shell/3.0.1209/ClientResources/dojo/dojo.js:15:33034) at null.<anonymous> (http://localhost:51873/EPiServer/CMS/3.0.1097/ClientResources/epi-cms/widgets.js:2:26459) at Object._16e.forEach (http://localhost:51873/EPiServer/Shell/3.0.1209/ClientResources/dojo/dojo.js:15:33034) at _ec._addCreateCommands (http://localhost:51873/EPiServer/CMS/3.0.1097/ClientResources/epi-cms/widgets.js:2:26427) epi.js:2 (anonymous function) epi.js:2 (anonymous function) dojo.js:15 _c6 dojo.js:15 _36 dojo.js:15 (anonymous function) dojo.js:15 _37 dojo.js:15 _7b dojo.js:15 _e8 dojo.js:15 _f28 widgets.js:2 _2f load-css.js:2 _27 load-css.js:2 _1a._1c.(anonymous function)._1c.(anonymous function) load-css.js:2

There was a file lock on something when updating the nuget packages. Not sure what it was since everything seemed to work fine yesterday. Today there is no edit mode. Admin mode works fine though.

Edited, Mar 18, 2014 12:15

I just had this error today I solved it by going to my \[SiteVPPFolder]\Modules\ and deleting the folders CMS and SHELL. If you read the readme file that is shown after the NuGet install it says that these should be deleted, but I think that if the site is running in the IIS there is a lock on the folders and therefore they can't be removed.

You should also look in the packages.config in the same folder some of the entries should also be removed, you can read about this in the readme file aswell.

Edited, Mar 18, 2014 12:19

Thank you Jacob, that did it!

I just assumed, since there was no error that everything went fine.

Mar 18, 2014 12:26

I just think that the leason for the future is that you should post the site in the IIS before installing NuGet packages. I will atleast be doing that from now on. But really glad I could help out.

Mar 18, 2014 12:31

I encountered the same issue as you guys, But when removing the CMS and Shell foldersunder the Modules folder the Episerver GUI is all messed up. Seems like those files were needed.

Actually it all worked on my local machine, but when deploying to the server I cannot reach the edit mode. Where did I go wrong?

Mar 20, 2014 8:20

In my project in the modules catalogue I have a folder called _protected. In that folder there are zipped folders named Must I unzip these?

Mar 20, 2014 8:26

No, they should not.

What version of those do you have? Open the zip in the CMS folder and read for the topmost folder, it should be

Mar 20, 2014 8:28

I have version

Mar 20, 2014 8:37

Hmm.. Then I have no idea. Any errors we can go on?

Mar 20, 2014 8:42

I get this error in chrome:

Mar 20, 2014 8:52

Just check to see if your version is the same in the Shell folder of ~/Modules/_protected/Shell/ :)

Mar 20, 2014 8:57

It is the same version in the Shell folder.

Mar 20, 2014 8:58

Just to make sure, the only two folders now in ~/VPP/Modules/ are:

  • EPiServer.Packaging
  • EPiServer.Packaging.UI



If so, I have no clue I'm afraid. :/

Edited, Mar 20, 2014 9:00

I have not deleted those folders, because if I do, all GUI layout in my episerver instance dissapears. This was my experience. But now when I deleted them aswell it worked as pure magic. =). Thanks for your support on my way getting there.

Mar 20, 2014 9:10

Glad to hear! :)

Mar 20, 2014 9:10

I'm glad that it worked out for you. But I am a bit curious of what actually happened.

We have some logging in our install scripts that should warn you when we can't delete/update the files that we need to update.

If we e.g. are not able to delete the CMS folder in the [AppData]\Modules folder you should see an message in the package-manager console saying something like "The package installer was unable to delete the folder ""$addOnFolderPath"". Please delete this folder and its contents manually." This should also be shown in a message box when the install.ps1 runs.

Did you install the packages from the package-manager console or the "Manage NuGet Packages" dialog?

Mar 20, 2014 14:35

@Magnus: Manage NuGet Packages.

Mar 21, 2014 19:18

@André: And you didn't see any popup or anything in the log afterwards? Have you been able to reproduce it?

Mar 24, 2014 7:10

The only message in pink I recieved was something like ""Directory '_protected' is not empty. Skipping...".

Edited, Mar 24, 2014 9:08

I also have some problems related to this. Could someone tell me how the modulesrepository folder should look like?

Apr 02, 2014 15:03

I was strugling with this problem and my solution was to delete everything except the EPiServer.Packaging and EPiServer.Packaging.UI folders in the [AppData]\Modules folder.

I also changed the configuration in Web.config for the section to include the following configuration:

    <publicModules rootPath="~/modules/" autoDiscovery="Modules" />
    <protectedModules rootPath="~/Manage/UI/">
      <add name="Shell" />
      <add name="CMS" />

I also changed the repository.config file to look like this:

<?xml version="1.0" encoding="utf-8"?>
  <package id="EPiServer.Packaging" version="3.0.1845" />
  <package id="EPiServer.Packaging.UI" version="3.0.1845" />


Edited, Apr 11, 2014 15:45

I got a similar error when upgrading to 7.7.0
For me it was the zip files in modules/_protected/CMS and modules/_protected/Shell that was not replaced when updating the nuget package.
Replacing them automatically solved it.

Apr 18, 2014 11:11

We had the same problem in our production environment when upgrading from 7.7.0 to 7.10.0. What we did was to

  • Delete everything inside [AppData]/Modules except repository.config. (That is, the folders CMS, EPiServer.Packaging, EPiServer.Packaging.UI, EPiServer.Suite and Shell, and the file Packages.config).
  • Delete the folder [AppData]/ModulesRepository

We had to shut down the IIS site while deleting, since IIS held a lock on the above files/folders.

Then after restarting, everything worked fine.

Jul 31, 2014 10:00

I think I have the same problem going from CMS 7.5 to CMS 8.1:

TypeError: Cannot read property 'label' of undefined
    at _53e.postscript (widgets.js:2)
    at new <anonymous> (dojo.js:15)
    at _25.initialize (widgets.js:2)
    at null.<anonymous> (epi.js:2)
    at lang.hitch (dojo.js:15)
    at _c8 (dojo.js:15)
    at _36 (dojo.js:15)
    at dojo.js:15
    at _37 (dojo.js:15)
    at _7c (dojo.js:15)(anonymous function) @ epi.js:2lang.hitch @ dojo.js:15_c8 @ dojo.js:15_36 @ dojo.js:15(anonymous function) @ dojo.js:15_37 @ dojo.js:15_7c @ dojo.js:15_ea @ dojo.js:15_102d @ widgets.js:2_2f @ load-css.js:2_27 @ load-css.js:2_1c.(anonymous function)._1c.(anonymous function) @ load-css.js:2

There are no folders/files in inside my [AppData]/Modules folder except these folders:

I've restarted the site several times.

Any ideas, anyone?

Apr 24, 2015 15:31
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.