Try our conversational search powered by Generative AI!

Import "EPiServer.Core.PropertyDate" error


When attempting to import files from 7.0.586.16 into all the content appears to import fine but none of my media files. The folders are created but the none of the images. The import data UI displays the message "You must enter a value between 01/01/1753 and 12/31/9999 for "EPiServer.Core.PropertyDate".

The log shows:

[58] ERROR EPiServer.Core.Transfer.TransferLogger: 10.5.3 Export/import error: You must enter a value between 01/01/1753 and 12/31/9999 for "EPiServer.Core.PropertyDate".
EPiServer.Core.OutOfRangePropertyValueException: You must enter a value between 01/01/1753 and 12/31/9999 for "EPiServer.Core.PropertyDate".
   at EPiServer.DataAccess.ContentDB.ThrowIfNotValidDateTime(DateTime date)
   at EPiServer.DataAccess.ContentSaveDB.GetSavedTime(IContent content)
   at EPiServer.DataAccess.ContentSaveDB.CreatePageVersion(String currentUser)
   at EPiServer.DataAccess.ContentSaveDB.CreateAndSave(String currentUser)
   at EPiServer.DataAccess.ContentSaveDB.<>c__DisplayClass16.<Save>b__15()
   at EPiServer.Data.Providers.SqlDatabaseHandler.<>c__DisplayClass4.<ExecuteTransaction>b__3()
   at EPiServer.Data.Providers.SqlDatabaseHandler.<>c__DisplayClass7`1.<ExecuteTransaction>b__6()
   at EPiServer.Data.Providers.SqlTransientErrorsRetryPolicy.Execute[TResult](Func`1 method)
   at EPiServer.DataAccess.ContentSaveDB.Save(IContent content, SaveAction action, String currentUser)
   at EPiServer.DataAbstraction.ContentStore.Save(IContent content, SaveAction action, String currentUser)
   at EPiServer.DefaultContentProvider.Save(IContent content, SaveAction action)
   at EPiServer.DataFactory.Save(IContent content, SaveAction action, AccessLevel access)
   at EPiServer.Core.Transfer.FileTransferObject.TransferACL(IContentMedia media)
   at EPiServer.Core.Transfer.FileTransferObject.OpenWrite(IContentTransferContext context)
   at EPiServer.Enterprise.DataImporter.InternalImportLive(IFileTransferObject metaData, ZipPackage package)
   at EPiServer.Enterprise.DataImporter.ImportFile(IFileTransferObject metaData, ZipPackage package)

I see there was a post last year with the same issue which didn't appear to get a resolution:

I need to be able to import this data otherwise I will not be able to migrate my site which makes upgrading pointless.

How can I get around this?

May 26, 2014 3:43


Would you mind to send me your data package? quma at



May 26, 2014 9:56

Thanks Quan, I've emailed you now.

May 27, 2014 1:31


When im trying to import data from episerver 6 to episerver 7.5 I got an error saying:

 Import has been canceled
The following errors have occurred:
[Importing content 25713_164563] Exception: Culture is not supported. Parameter name: name CZ is an invalid culture identifier.

I have Czech culture enabled on target and source.

How can i fix this. I tried rename export file to zip and change some CZ to CS but when i zip it again i got different filesize and episerver says its corrupt.

Any help is much appreciated.


Aug 12, 2014 16:17


Would you mind sharing your solution here so we can use it for future reference?

Dec 12, 2014 17:03

Any updates on the "You must enter a value between 01/01/1753 and 12/31/9999 for "EPiServer.Core.PropertyDate"" error ? 

Having the same issue when importing files (images).

Dec 15, 2014 0:37

I just experienced this too, and one possible error is:

Rename the exported file to, extract it and open all the different XML-files. In some of them, a language/culture is given at the root element. Does this match your page culture?

In my case it said en-US, even though all content that was being exported was nb-NO. I fixed all these, zipped the file back down and renamed to ".episerverdata". Upload and import => Success.

So it seems like a bug to me...

Edited, Nov 13, 2015 15:23
<p>I know it&acute;s been a while since anyone posted in this thread, but I&acute;m curious as to whether&nbsp;anyone found a solution to this problem?</p> <p>Tried the solution suggested by Arve and the language/culture&nbsp;appears&nbsp;to be wrong in my case as well, but even after correcting the xml-files the import fails with the error:</p> <p>EPiServer.Core.Transfer.TransferLogger: 10.5.3 Export/import error: Du m&aring;ste ange ett v&auml;rde mellan 01/01/1753 och 12/31/9999 f&ouml;r "EPiServer.Core.PropertyDate".</p> <p>(swedish: Y<span>ou must enter a value between&nbsp;</span><em>01/01/</em><em>1753&nbsp;</em><span>and&nbsp;</span><em>12/31/9999</em><span>&nbsp;for "</span><em>EPiServer.Core.PropertyDate")</em></p> <p>I&acute;m importing from EPiServer 7.1 to EPiServer 10.10.4.</p> <p>Regards</p> <p>/Daniel</p>
Nov 20, 2017 12:59
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.