Our monthly Virtual Happy Hour is happening this week, Fri Feb 23!

Try our conversational search powered by Generative AI!

AlloyContentAreaRenderer not working

Vote:
 

Hi,
    I am new to EPiServer, trying to understand it by replicating Alloy MVC template project (v7.5)
I already did replicating Alloy template with web forms (v7.0), where i noticed that to implement Bootstrap layout
SitePropertyContentAreaControl class has been used. With MVC version (AlloyContentAreaRenderer), i see lesser code to implement the same via DisplayOptions.

    Right now am facing issue where breakpoint never goes into AlloyContentAreaRenderer class (no styles applying when render) and throws no errors,
i tried with .Net4.0 and .Net4.5 too and tried comparing/updating config files and dll references but its not working, please anyone help me.
am using MVC 4.0 with iisexpress (yes i see breakpoint touch in DependencyResolverInitialization class).
 Thanks.

#114967
Jan 06, 2015 15:08
Vote:
 

Hi Raju, in your dependency resolver class do you have a line assigning your custom renderer to be used for contentarea renderers?  For example in my DependencyResolverInitialisation.cs I have a line where i add this to the container:

private static void ConfigureContainer(ConfigurationExpression container)
{

container.For<ContentAreaRenderer>().Use<GridGalleryContentAreaRenderer>();

}


with GridGalleryContentAreaRenderer being your custom class (AlloyContentAreaRenderer in your case).

#115006
Edited, Jan 07, 2015 17:13
Vote:
 

Hi Adam,

Yes, I have that line in DependencyResolverInitialisation.cs class and breakpoint touches the line while debugging.

but doesn't touches the breakpoint set in AlloyContentAreaRenderer constructor.

Am just rewriting the alloy mvc template project for understanding, and stuck here.

Thanks.

#115018
Jan 08, 2015 5:56
Vote:
 

No Trace found on the issue. Had to create a new site (MVC4 project), copied files and imported data.

#115095
Jan 09, 2015 10:22
Vote:
 

Hello Raju,

We're facing the exact same problem here with the breakpoint touching our dependency resolver class but not touching our implementation of the ContentAreaRenderer. Did you, or anyone else, figure out what caused this problem to appear? Don't want to have to create a new project to get this to work so hope for a better solution to this issue.

Best regards

Martin

#118371
Mar 05, 2015 10:01
Vote:
 

Hello again Raju,

I might have found a solution to why this didn't work in our solution. I understand that it's a bit late for your project but take a look at this forum post: http://world.episerver.com/Modules/Forum/Pages/thread.aspx?id=118450

Best regards

Martin

#118457
Mar 06, 2015 14:53
Vote:
 

Hi Martin,

Thanks for the solution.

#118497
Mar 09, 2015 6:57
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.