SaaS CMS has officially launched! Learn more now.

Could not add component

Vote:
 

Hi guys,

I currently have a weird problem when i try to add new gadgets in editormode. I noticed this when i wanted to add the version controller gadget and a alert box said "Error: could not add component".

I have tried to add all the gadgets but I get the same error everytime.

In the console i get the following message:

This problem occurs only in our production enviroment and not in dev enviroment. 

Im relatively new at EPiServer so any suggestion is helpful :)

#114982
Jan 07, 2015 9:35
Vote:
 

Hi! If you click on the error marked with red at the bottom of the Network tab and then click on the "Response" tab, do you get a more detailed error message?

#115011
Jan 07, 2015 20:30
Vote:
 

Hi Mattias,

Thanks for your reply! Here you have another dump.

#115022
Jan 08, 2015 9:35
Vote:
 

This solved my problem if someone else gets the same error.

var storeDefinition = StoreDefinition.Get(DynamicDataStoreFactory.Instance.GetStoreNameForType(typeof(ComponentData)));
 
storeDefinition.Remap(typeof(ComponentData));
 
storeDefinition.CommitChanges();

Source: http://world.episerver.com/Modules/Forum/Pages/Thread.aspx?id=85262&epslanguage=en

#115301
Jan 13, 2015 13:31
Vote:
 
#155506
Edited, Sep 19, 2016 17:23
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.