Episerver Search Index reset / no segments error messages


I am working to get Search implemented on a production server.  I've gone through a number of articles already and have tried a number of the troubleshooting recommended.  After enabling Logging (thanks you Josh), I am getting errors that at least tell me I'm close.

Here is a snippet:

2015-11-17 11:20:57,614 [20] ERROR EPiServer.Search.IndexingService.IndexingService: Failed to write to index: 'default'. Message: no segments* file found in Lucene.Net.Store.SimpleFSDirectory@F:\**siteurl**\web\..\App_Data\Index\Main lockFactory=Lucene.Net.Store.NativeFSLockFactory: files:write.lock
at Lucene.Net.Index.SegmentInfos.FindSegmentsFile.Run(IndexCommit commit)
at Lucene.Net.Index.SegmentInfos.Read(Directory directory)
at Lucene.Net.Index.IndexWriter.Init(Directory d, Analyzer a, Boolean create, IndexDeletionPolicy deletionPolicy, Int32 maxFieldLength, IndexingChain indexingChain, IndexCommit commit)
at Lucene.Net.Index.IndexWriter..ctor(Directory d, Analyzer a, Boolean create, MaxFieldLength mfl)
at EPiServer.Search.IndexingService.IndexingServiceHandler.WriteToIndex(String itemId, Document doc, NamedIndex namedIndex)

I have been checking to make sure permissions are set for the folder in question and I the app_pool Identity has "modify" rights to the folder. 

Something I'd like to clearify, is the following path something I should modify:


I've cleared out the "Index" folder and even deleted it a couple of times but every time to try to re-index using the following URL (http://**siteurl**/episerver/cms/admin/indexcontent.aspx)  I start to produce errors like the above. 

Here are the web.config settings I'm working with at the moment:

ip6Address="::/0" readonly="false" />

Any help would be greatly appreciated,


Nov 17, 2015 19:45

Okay - I got it to work but I am not entirely sure why.  

I came across this recommendation and it worked for me.  I can only assume that deleting the Index folder and it content broke some number of references that left indexing in a corrupted state.

The recommendation was to rename the index folder (forgive me for not locating your post but Thank you thank you thank you!!).

Once I did that, the indexing service kicked in and away it went.



Nov 17, 2015 20:16

Thanks a lot for this, helped us to fix the simmilar issue!

Aug 11, 2017 5:42
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.