Try our conversational search powered by Generative AI!

External component has thrown an exception



I can login to the CMS on my local site running EPiServer Edit mode works without any problems but when I try to go the Admin mode I get this:


External component has thrown an exception.
System.Web.HttpCompileException (0x80004005): External component has thrown an exception.
at System.Web.Compilation.AssemblyBuilder.Compile()
at System.Web.Compilation.BuildProvidersCompiler.PerformBuild()
at System.Web.Compilation.ThemeDirectoryCompiler.GetThemeBuildResultType(String themeName)
at System.Web.Compilation.ThemeDirectoryCompiler.GetThemeBuildResultType(HttpContext context, String themeName)
at System.Web.UI.Page.InitializeThemes()
at System.Web.UI.Page.PerformPreInit()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
at System.Web.UI.Page.ProcessRequest()
at System.Web.UI.Page.ProcessRequest(HttpContext context)
at ASP.episerver_cms_admin_default_aspx.ProcessRequest(HttpContext context) in c:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\6df7b224\256e77ca\App_Web_mtnzxpkp.6.cs:line 0
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)


Anyone knows what causes this problem?

I should mention that the application worked fine before but suddenly started to show this error message. I have tried to restart the IIS, removing ASP temporary files and even starting the machine but none of them helped. 

Thank you in advance,


Nov 26, 2015 17:25

Hello Masoud

Did you manage to solve this problem? I'm running v9.3.0.0 and everything works in dev and test, had an initial deploy uploaded to the production environment which ran just fine.
When publishing the latest code to production i get the same error as you.

Tried setting up an new site with production files and database which worked oob.

Kind regards


Dec 10, 2015 15:33

Is there any error message in log files?

Dec 16, 2015 15:48

@Martin Johansson

I had the exact same error.

EPiServer version 9.3.1

Windows Server 2012 R2

Deploy to production worked fine the first time and then stopped working two days later.

A restart of the production server solved the issue.

Mar 04, 2016 15:18

I would guess that temporary files is messing things up. Try deleting those...

Happens from time to time...

Edited, Mar 04, 2016 15:33


Cleanup of temporary did resolve the issue only to rise again, the main problem was with a couple of wiindows updates.

Read more @

Mar 16, 2016 9:38
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.