Challenges with localization of properties in EPiServer



For some reason EPiServer does not pickup our localized texts for property labels, but instead use the english texts. I have checked the following:

- ContentLanguage.PreferredCulture is 'da'
- CultureInfo.CurrentUICulture is 'da'

When retrieving language-texts for content from the language-file, the 'da' texts are correctly retrieved, so it only seems to be a problem when retrieving texts for localized properties for EPiServer.

This is my language file:

            Dette er caption

This is my housedetailspage.cs:

[ContentType(GUID = "{86F79F87-89A2-4B49-9992-BAE2FFCA88D2}",
        GroupName = "Test",
        DisplayName = "Housedetails page",
        Description = "The page")]
public class HouseDetailsPage : BaseViewPage
        [Display(GroupName = SystemTabNames.Content, Order = 100, Name = "HouseId", Description = "Used in EditMode only")]
        public virtual string HouseId { get; set; }

BaseViewPage is a class that inherits directly from PageData.

Any input is appreciated :)

Best regards


Feb 24, 2015 9:00

Hi Jesper,

Your language file looks fine.

I have similar problem. Localized text is cached on server side and in browser.
It works when I kill the IIS from task manager, run the website, clear browser cache, and refresh the page :)

Feb 24, 2015 10:46

Can you also try to remove <menuitems> section from your language file and see what happens?

After adding <menuitems> section in my language files, edit mode breaks: blank screen, no page tree, etc.

Feb 24, 2015 11:00


I just tried to remove the <menuitems> element and I am afraid it did not help.

Thank you for your suggestion though!

Feb 24, 2015 11:19
Feb 26, 2015 15:44

Alright, problem solved. 

Language-files checked out to be ok.

It was a silly mistake with a missing user-language not being set (Episerver --> "My settings" --> "Display options" --> "Personal language")

Feb 27, 2015 11:19
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.