Vulnerability in EPiServer.Forms

Try our conversational search powered by Generative AI!

Problems connecting to database on new site

Vote:
 

I am an absolute beginner so please forgive me.  I have installed EPiServer v8.0 and am having trouble connecting to the database.  I get this error when I hit F5 from Visual Studio:

"A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 50 - Local Database Runtime error occurred. Error occurred during LocalDB instance startup: unable to create the SQL Server process."

The site was created from within VS using the New...Project method.  VS is running as Administrator.  The site is an empty EpiServer site, the only files I have added are a StartPage class file.

As a side note, I successfully installed the Alloy site and that works just fine.

I am using Visual Studio 2013.

#120549
Apr 20, 2015 13:11
Vote:
 

If you are running under IIS (and not IIS Express) then you would need to move either to SQL Server or SQL Server Express to access DB from IIS process.

If you are still in IIS Express - http://stackoverflow.com/questions/13287252/cannot-start-localdb may help.

#120553
Apr 20, 2015 13:52
Vote:
 

I am using IIS Express.  I have tried deleting the EPiServer site and starting again but I get the same result.

Looking in my Event Viewer I see lots of errors from SQLLocalDB 12.0:

"Windows API call CreateProcessAsUserW returned error code: 740. Windows system error message is: The requested operation requires elevation.
Reported at line: 3705. "

#120557
Apr 20, 2015 14:33
Vote:
 

I found the solution.  LocalDB was not running.  I can only guess that it was running when I installed Alloy, then at some point it stopped which broke the install for the empty site.

#120565
Apr 20, 2015 16:30
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.