Try our conversational search powered by Generative AI!

Cannot edit dynamic properties in EPiServer 8


I have a strange issue going on. I've updated a client's site to update 70 (was at 7.5 before).

Now, after clicking the Tools -> Dynamic Properties on a page, the modal popup shown does not compare the usual dynamic property editors, but instead it renders the front page inside the Dynamic Properties popup.

Browser console shows no errors.

I have not been able to recreate this in vanilla Alloy site yet.

Any suggestions? Thanks!

Jul 02, 2015 16:02

So far I've found out that the Dynamic Property popup actually loads an url within an iframe: /episerver/CMS/Edit/EditDynProp.aspx?moduleArea=LegacyCMS&id=1234&IsInLegacyWrapper=true
When trying to access the URL directly, I get the same result as in the modal popup, the startpage is shown. 

Fiddler does not show any redirects, only a 200. EPiserver log shows nothing of interest (with debug-flag enabled).

I think there is some routing going on. If I use a non-existing Page ID in the query string (or remove the query string all together) I am able to see the "normal" dynamic properties for the startpage.

I tried making a copy of EditDynProp.aspx and copied the code-behind from EPiServer.UI.Edit to do do some debugging.
Then I put a couple of breakpoints in the OnLoad and OnInit methods. What's strange is that my breakpoint are never hit when the URL contains the query strings. Without them the breakpoints are hit though.

Jul 03, 2015 11:15

I found the cause.

We put this in to deal with classic urls, I guess it conflicts with the dyn.prop window as well. Removing it solved it for me.


        protected override void RegisterRoutes(System.Web.Routing.RouteCollection routes)
            routes.Insert(0, ServiceLocator.Current.GetInstance<ClassicLinkRoute>());

Jul 03, 2015 11:36
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.