Try our conversational search powered by Generative AI!

Episerver CMS completely falls apart after package installation


I just stumbled upon a problem that completely breaks my Episerver CMS solution.

I had a fine working CMS implementation (checked into source control), but after reading about a 'content collaboration' nuget package i tried to install that in the solution. Sadly....the whole solution now falls apart, and what's even worse, even if i go back to my previous version it still falls apart!

Can anyone help me with this since the project now came to a complete halt. Probably something is also changed in the database, since i can't get the solution running anymore..... HELP!

The error reads 'Value cannot be null. Parameter name: type'

The rest reads like this: 

[ArgumentNullException: Waarde kan niet null zijn.
Parameter name: type]
   System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) +11124884
   System.Activator.CreateInstance(Type type, Object[] args) +79
   EPiServer.Shell.Modules.ModuleFinder.GetModuleInDirectory(String routeBasePath, String moduleResourcePath, IEnumerable`1 configuredAssemblyNames, AutoDiscoveryLevel discoveryMode, String configuredName) +486
   EPiServer.Shell.Modules.<>c__DisplayClass1.b__0(VirtualDirectory moduleDirectory) +117
   System.Threading.Tasks.<>c__DisplayClass32`2.b__30() +1229
   System.Threading.Tasks.Task.InnerInvoke() +72
   System.Threading.Tasks.Task.InnerInvokeWithArg(Task childTask) +17
   System.Threading.Tasks.<>c__DisplayClass11.b__10(Object param0) +198

[AggregateException: Er zijn één of meer fouten opgetreden.]
   System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions) +3834425
   System.Threading.Tasks.Task.Wait(Int32 millisecondsTimeout, CancellationToken cancellationToken) +10919077
   System.Threading.Tasks.Task.Wait() +10
   System.Threading.Tasks.Parallel.PartitionerForEachWorker(Partitioner`1 source, ParallelOptions parallelOptions, Action`1 simpleBody, Action`2 bodyWithState, Action`3 bodyWithStateAndIndex, Func`4 bodyWithStateAndLocal, Func`5 bodyWithEverything, Func`1 localInit, Action`1 localFinally) +691
   System.Threading.Tasks.Parallel.ForEachWorker(IEnumerable`1 source, ParallelOptions parallelOptions, Action`1 body, Action`2 bodyWithState, Action`3 bodyWithStateAndIndex, Func`4 bodyWithStateAndLocal, Func`5 bodyWithEverything, Func`1 localInit, Action`1 localFinally) +239
   System.Threading.Tasks.Parallel.ForEach(IEnumerable`1 source, Action`1 body) +110
   EPiServer.Shell.Modules.ModuleFinder.GetModulesInSubdirectories(String rootPath, AutoDiscoveryLevel discoveryMode) +282
   EPiServer.Packaging.Utility.PackagingModuleProvider.GetModules() +233
   EPiServer.Shell.ShellInitialization.b__1d(IModuleProvider p) +8
   System.Linq.d__14`2.MoveNext() +234
   System.Collections.Generic.List`1..ctor(IEnumerable`1 collection) +439
   System.Linq.Enumerable.ToList(IEnumerable`1 source) +58
   EPiServer.Shell.Modules.ShellModule.MergeDuplicateModules(IEnumerable`1 modules) +34
   EPiServer.Shell.ShellInitialization.GetConfiguredModules(IServiceLocator locator) +111
   EPiServer.Shell.ShellInitialization.Initialize(InitializationEngine context) +81
   EPiServer.Framework.Initialization.<>c__DisplayClass5.b__4() +19
   EPiServer.Framework.Initialization.ModuleNode.Execute(Action a, String key) +43
   EPiServer.Framework.Initialization.ModuleNode.Initialize(InitializationEngine context) +80
   EPiServer.Framework.Initialization.InitializationEngine.InitializeModules() +173

[InitializationException: Initialize action failed for Initialize on class EPiServer.Shell.ShellInitialization, EPiServer.Shell, Version=, Culture=neutral, PublicKeyToken=8fe83dea738b45b7]
   EPiServer.Framework.Initialization.InitializationEngine.InitializeModules() +439
   EPiServer.Framework.Initialization.InitializationEngine.Initialize(HostType hostType) +116
   EPiServer.Framework.Initialization.InitializationModule.Initialize(HostType hostType) +446
   EPiServer.Framework.Initialization.InitializationModule.FrameworkInitialization(HostType hostType) +83
   EPiServer.Global..ctor() +76
   EPiServer8.EPiServerApplication..ctor() +29
   ASP.global_asax..ctor() in c:\----------\AppData\Local\Temp\Temporary ASP.NET Files\vs\ef0ae057\7c74a266\App_global.asax.0.cs:0
Jul 03, 2015 12:33

I'd check a couple of things.

If this is a new EPiServer update you've tried to install, try manually deleting everything in your /bin/ folder before doing a fresh compile in VS.

When rolling back, if your website is still active (the IIS process), the zip files in your /modules/ folder might not have been rolled back, as the IIS process are using them.

If everything else fails, try deleting everything in your ASP.NET temp folder. The path should be something like:
C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files 

Jul 03, 2015 12:44

Ron, did you manage to resolve this? I am struggling with the same exception and would be helpful to understand what helped you resolve this.

Nov 19, 2015 18:31

Hi Manish, What did it for me was disable the Content Collaboration addon. This plugin made the whole system unstable. After that Episerver worked again. But since then there were quite a bit of upgrades so i don't know about the current situation. Good luck with these errors.

Nov 20, 2015 11:14

Thanks Ron. Managed to resolve it.

Turns out that rootPath for publicModules under epiServer.Shell config section was incorrect in our case.

Nov 20, 2015 18:31
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.