SaaS CMS has officially launched! Learn more now.

The form could not be sent to an e-mail address

Vote:
 

Hi,

I'm struggling to find a solution in the forums about my issue altho this seems to be basic one.

I have an XForm with the following settings:

  • Form can be sent without logging in
  • Same person can send the form several times
  • Result from sending: Save to database

This form works without any issues. When a user submits the form, the system redirects to a "Thank you" page.

However, when I change the 'Result from sending' property to 'Send e-mail', the ModelState suddenly becomes false with the following error:

  • The form could not be sent to an e-mail address

I have tried a couple of things:

  • Added this to me web.config 
  • Setup the SMTP E-mail on IIS Management console using the same SOME_IP_ADDRESS value above

Both solutions didn't work.

I do know that I have the right IP Address as I installed an SMTP-client on the same server and was able to send emails successfully.

I'm running an ASP.NET MVC application using EPiServer 8.9.

Any help would be highly appreciated!

Thanks,

Nicola

#131439
Jul 26, 2015 7:52
Vote:
 

Hi Nicola,

Do you have smtp settings defined in web.config:

<system.net>
  <mailSettings>
    <smtp from="REPLACE_THIS">
      <network host="REPLACE_THIS" />
    </smtp>
  </mailSettings>
</system.net>

Does it work if you save emails on the file system:

<system.net>  
    <mailSettings>    
        <smtp deliveryMethod="SpecifiedPickupDirectory" from="no-reply@localhost.com">      
            <specifiedPickupDirectory pickupDirectoryLocation="C:\SomePath" />    
        </smtp>  
    </mailSettings>
</system.net>

Have you checked log files?

#131441
Jul 26, 2015 22:19
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.