Hi, I'm working with this configuration form Membership providers in Episerver 8:

 <>membership defaultProvider="MultiplexingMembershipProvider" userIsOnlineTimeWindow="10" hashAlgorithmType="HMACSHA512">
        <>clear />
        <>add name="MultiplexingMembershipProvider" type="EPiServer.Security.MultiplexingMembershipProvider, EPiServer.Framework" provider1="SqlServerMembershipProvider" provider2="WindowsMembershipProvider" />
        <>add name="WindowsMembershipProvider" type="EPiServer.Security.WindowsMembershipProvider, EPiServer" deletePrefix="BUILTIN\" searchByEmail="true" />
        <>add name="SqlServerMembershipProvider" type="System.Web.Providers.DefaultMembershipProvider, System.Web.Providers, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="EPiServerDB" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="true" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" applicationName="/" />
    <>roleManager enabled="true" defaultProvider="MultiplexingRoleProvider" cacheRolesInCookie="true">
        <>clear />
        <>add name="MultiplexingRoleProvider" type="EPiServer.Security.MultiplexingRoleProvider, EPiServer.Framework" provider1="SqlServerRoleProvider" provider2="WindowsRoleProvider" providerMap1="SqlServerMembershipProvider" providerMap2="WindowsMembershipProvider" />
        <>add name="WindowsRoleProvider" applicationName="/" type="EPiServer.Security.WindowsRoleProvider, EPiServer" />
        <>add name="SqlServerRoleProvider" type="System.Web.Providers.DefaultRoleProvider, System.Web.Providers, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="EPiServerDB" applicationName="/" />

I can access to Episerver back-end with an admin user, the same I'm logged in with windows. Now I would like to add some users for Episerver groups (WebAdmins, WebEditors).

When I try to administer groups in Episerver, I can see a page with windows groups, but I don't know why I can't see there Episerver default groups like WebAdmins or Webeditors.


Aug 03, 2015 10:38

I've the following virtualroles:

 <virtualRoles addClaims="true">
        <add name="Administrators" type="EPiServer.Security.WindowsAdministratorsRole, EPiServer.Framework" />
        <add name="Everyone" type="EPiServer.Security.EveryoneRole, EPiServer.Framework" />
        <add name="Authenticated" type="EPiServer.Security.AuthenticatedRole, EPiServer.Framework" />
        <add name="Anonymous" type="EPiServer.Security.AnonymousRole, EPiServer.Framework" />
        <add name="CmsAdmins" type="EPiServer.Security.MappedRole, EPiServer.Framework" roles="WebAdmins, Administrators" mode="Any" />
        <add name="CmsEditors" type="EPiServer.Security.MappedRole, EPiServer.Framework" roles="WebEditors" mode="Any" />
        <add name="Creator" type="EPiServer.Security.CreatorRole, EPiServer" />
        <add name="PackagingAdmins" type="EPiServer.Security.MappedRole, EPiServer.Framework" roles="WebAdmins, Administrators" mode="Any" />

These are the groups I would like to see when accessing Episerver groups, how can I achieve that???
Aug 03, 2015 11:10

WebAdmins and WebEditors are not default groups in EPiServer. You have to create them manually.

Aug 03, 2015 11:34

Hi Dejan, I'm following your:, but I'm using VS 2013 (so no option ASP.NET configuration), and don't understand the solution with temp.aspx, or how can I manage groups/users from IIS, could you explain these solutions????


Aug 03, 2015 11:45

If you already have access to admin mode, you can simply create users / groups from there.

Solution with .aspx file: (you have to change default role and membership providers to SqlServerMembershipProvider and SqlServerRoleProvider. ASPX solution doesn't work with MultiplexingMembershipProvider / MultiplexingRoleProvider)

Aug 03, 2015 11:53
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.