Try our conversational search powered by Generative AI!

Getting error after Blank EPi server website template : {authenticationSuccessful:false}


I have installed EPIserver visual studio extension then created one project with EPiserver website blank template

it builds successfully but after run if i tried to hit http://localhost:58085/episerver then it redirect to http://localhost:58085/Util/login.aspx?ReturnUrl=%2fepiserver

and shows error "{authenticationSuccessful:false}"

how to resolve this issues i tried multiple ways but still no clue.

I am not getting any complile or runtime error, not able to debug because template is blank

EPiServer Team please reply with solution.

Sep 30, 2015 13:21


I tested this behavior in the latest version of the VS extension. I created a new project, selected EPiServer, Empty site (selected MVC) and was able to compile and go to http://localhost/episerver. 

Did you select MVC or Webforms when you created the empty site?

I get your URL: http://localhost/Util/login.aspx?ReturnUrl=%2fepiserver Not able to reproduce your problem, however. I would make sure that your development environment has the necessary requirements:

Sep 30, 2015 22:48

I did same what you have written, selected MVC and my system requirement is same as you send in link - still i am getting this issue.

SQL server - 2014

Visual studio 2013

OS - windows 8

Browser - chrome


DOt Net framework 4.5

What more information do you need from me? pls suggest 

Oct 01, 2015 6:40

I can't reproduce this myself, but since you're selecting an MVC-based solution, do you have at least MVC 4/5 installed in your environment?

Oct 03, 2015 0:58

I am also experiencing the same problem. The blank template uses DefaultProfileProvider which is configured in Web.config as MultiplexingMembershipProvider, combination of WindowsMembershipProvider and SQLMembershipProvider. I am not part of local admin group of my Windows laptop. There is an Avecto DefendPoint software which is elevating the privilege if solution is placed inside Development_Avecto folder in C:/ or D:/ drive. The Alloy template is working absolutely fine because it uses ASPNET Identity as a connection provider. Is there any way to make blank Episerver template working without having admin access onto laptop ?

Following is the default generated Web.Config provider section for your reference - 

<add name="DefaultProfileProvider" type="System.Web.Providers.DefaultProfileProvider, System.Web.Providers, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="EPiServerDB" applicationName="/" />
<membership defaultProvider="MultiplexingMembershipProvider" userIsOnlineTimeWindow="10" hashAlgorithmType="HMACSHA512">
<clear />
<add name="MultiplexingMembershipProvider" type="EPiServer.Security.MultiplexingMembershipProvider, EPiServer.Framework.AspNet" provider1="SqlServerMembershipProvider" provider2="WindowsMembershipProvider" />
<add name="WindowsMembershipProvider" type="EPiServer.Security.WindowsMembershipProvider, EPiServer.Cms.AspNet" deletePrefix="BUILTIN\" searchByEmail="true" />
<add name="SqlServerMembershipProvider" type="System.Web.Providers.DefaultMembershipProvider, System.Web.Providers, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="EPiServerDB" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" applicationName="/" />
<roleManager enabled="true" defaultProvider="MultiplexingRoleProvider" cacheRolesInCookie="true">
<clear />
<add name="MultiplexingRoleProvider" type="EPiServer.Security.MultiplexingRoleProvider, EPiServer.Framework.AspNet" provider1="SqlServerRoleProvider" provider2="WindowsRoleProvider" providerMap1="SqlServerMembershipProvider" providerMap2="WindowsMembershipProvider" />
<add name="WindowsRoleProvider" applicationName="/" type="EPiServer.Security.WindowsRoleProvider, EPiServer.Cms.AspNet" />
<add name="SqlServerRoleProvider" type="System.Web.Providers.DefaultRoleProvider, System.Web.Providers, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="EPiServerDB" applicationName="/" />

Feb 16, 2018 15:24
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.