Try our conversational search powered by Generative AI!

Edit mode running in debug mode?


We´re currently investigating an application (CMS version 9.8.0) where the edit mode loads really slow, much slower than other applications I´ve been comparing with. We found that on the stage environment (DXC) for the application, the edit mode loads like 700 more items than on other environments and we think it´s due to the edit mode running in some sort of debug mode. Browsing to the file returns a message saying:

/* Dummy file to trick the AMD loader when running debug mode */

Browsing to the same file on production or local dev box returns a minified js file as expected. How can one put the edit mode in debug mode like this? And how do we fix it? A colleague mentioned that he saw somewhere that it could be set in module.config somehow, but I haven´t found a resources about it that helped me. This is probably not the whole reason for edit mode being extremely slow but I feel this is something that we should fix.

Has anyone encountered this before and have a solution?


Dec 07, 2016 8:35

In EPiServerFramework.config check for <clientResources debug="true" />

Dec 07, 2016 12:07

And if it´s not in the module.config that is live on that environment, what else could it be? Since this is DXC I checked if there could be a setting in the Azure portal but haven´t found anything on any environment we have access to either. I saw the post you linked to but didn´t get that it was the same thing since that post mentioned that you needed to install a NuGet package called EPiServer.CMS.UI.Sources which isn´t installed in this solution.

Dec 07, 2016 12:31

Not sure if you managed to resolve the issue.

The <clientResources debug="true" /> is not located in the module.config but in the <episerver.framework> section that might be in web.config or another config file depending on how the system has been setup.

When you set it to false it should load the minified files.

Jan 18, 2017 14:02

Thanks Magnus! It was still an open issue...

I found it now on the clients stage environment where the issue was found. I was thrown off by the other post, there was something about module.config there before (I guess it has been updated now).


EDIT: Can´t mark anything as answer apart from my own entries which aren´t the answer :)

Edited, Jan 18, 2017 14:17


I will mark my answer as the answer and talk to the world team so you can mark other answers as "the" answer

Jan 18, 2017 14:23

Super! I thought that we were supposed to be able to do that already :)

Jan 18, 2017 14:25
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.