Try our conversational search powered by Generative AI!

Page tree not showing in CMS Edit mode


I've deployed site to customers server and it works fine, except edit mode which is not showing page tree. In console there are 20 error message and all are same "error loading ROOT children"

For some reason all calls to 


returns 404, and responseText is empty.

On dev machine this is working withouth any problems but i don't know why is this happening on server.

Edited, Dec 22, 2016 13:23

Can you Confirm, you have complete modules folder on Prod?


Dec 22, 2016 15:02

Hi Khan,

Yes i have all of them, same as on dev machine






All other parts of CMS are working fine, only Edit is not.

Dec 22, 2016 15:08

EpiServer cms Version?
Can you double check IIS settings also, Is there any virtual directory for modues?
Do you deploy site on servers manually or using tools like Octopus?

Other reasons that i can think of is access issues or certificate issue, but those are very unlikely. Try an appication pool reccyle also. 


Edited, Dec 22, 2016 15:51

Hi Khan,

I'm using EPiServer v10.2.0.

I've checked IIS and there is no virtual directory for modules, and deployment is done manually. Before deploying to server i've checked published files and site is working without any problems but once its deployed this problem occurs. We are hosting under http so no certificated is required and i tried with recycle app pool and deleting .net temporary files but nothing helped. 

Dec 22, 2016 16:26

I did a quick test in my local for me http://mywebsite/EPiServer/cms/Stores/contentstructure/ returns {}&&[]

Try to access this url in browser window also from the server. that may help your investigation, Try some other urls also e.g.

Dec 22, 2016 16:33

Hi Khan,

I tried that also but response is 404 as well

this is from server:

And this is from dev machine

Dec 22, 2016 16:39

Just to be on the safe side: check tblContent in the cms database and see if it too has a post with id 3 and compare it with the content in your dev environment.

Especially look at the parent and content type.

If it isn't a data issue you are stuck with debugging the routing. :(


Dec 22, 2016 17:09

Hi Erik,

Thanks for response, but yes all content is same. I can open site without any problems and all pages/structure is same as on dev machine, all is working fine. Only problem is with CMS edit section there is no data, and both endpoints /stores/contentstructure/ and /stores/contentdata/ returns 404, so it must be some problem with routing but i don't know how to fix it nor debug it.



Dec 25, 2016 12:12

Have you tried this ? 

Dec 27, 2016 14:41

Hi Mahul,

Thanks for your respons but i've found problem.

In event viewer warning was logged with error message “Could not map property ContentGuid - table tblBigTable does not contain any columns that map to DbType.Guid” which was caused by restoring DB using generated scripts. I've restored DB from 2014 SQL to version 2008 R2, using 2008 compatibility mode and that produced error, so i've repet generating scripts but this time using 2008R2 compatibility mode and problem was solved.

This post helped me a lot

Dec 27, 2016 16:42
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.