Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

EPiServer 9 multi site different master lanugages

Vote:
 

So I have a DXC multisite application where I want to easily have different sites with different master language. Now, the first time a page is created, the master language for that page is the language in which it is created yes, but when I create a new start page it is outside of exisiting sites so how do I easily controll in which language that site should initially be created. 

One sollution I thought of was to have a demo/test/creation site with all possible languages activated, then just create the start page there and move it out, but I'd prefer to be able to do it directly in the root but can't figure out a simple solution.

Any tips/advice?

#144423
Feb 12, 2016 14:22
Vote:
 

Restrict editor languages on root page, set available language and then create start page?

#144426
Feb 12, 2016 14:51
Vote:
 

set available language on root page would be ouchy if existing pages inherit configurations from root though, so then I would have to remove that.

However I'm getting some serious issues with the entire language handling right now.

If I have yyy.yyyyy.yy set up in hosts in site settings without a culture. I have sv and en enabled on the site and in admin. then I get the behaviour that when I switch language, all pages still show as non italic and if I click on a page, its shows as "this content is in english, switch to english to edit". I cannot translate.

Then I tried setting yyy.yyyy.yy to use culture sv. 
All of the sudden, entering a page asks if I want to translate it. However, when I try and switch language in site, the language and viewlanguage queries updates, but the tree still shows in swedish (italic now) and the page asks if I want to translate it. I cannot switch away from english anymore.

#144434
Feb 12, 2016 15:00
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.