Try our conversational search powered by Generative AI!

Blocks, pages and globalization


Hi there,

I'm experiencing the following, which may or may not be by design;

  • I have a page in norwegian

  • I add a norwegian block to the content area property in that page

  • I then switch to english

  • Epi asks me if I want ot translate the page, I click "yes"

  • I save and publish.

  • Now - notice that I havent translated the block to english yet. However, when viewing the english page, the norwegian block is displayed.

Am I missing something here? I would assume that the block should not show, as it is not available in the correct language.


Apr 08, 2016 14:24

If you set culturespecific attribute on the content area you shouldn't see any block. If you are missing that attribute then the content area will be shared between languages so it will have a Norwegian block there and whether to display it should depend on fallback and replacement language I guess. 

Edited, Apr 08, 2016 15:15

Thank you for your reply.

I think I need to rephrase my question. The behavior I'm describing will only happen when in edit-mode. In view-mode the untranslated blocks are not shown, so that's fine.

However, this is a bit confusing for the client. What I'd like is to hide untranslated content for the current language - also when in edit-mode. 

Apr 13, 2016 7:53

Tried the edit setting for hiding content not in current language?

That solved the opposite problem for me :)

Apr 13, 2016 8:36

I think that setting only affects the page tree? It does not seem to make any difference for how the page content is rendered in the Preview-window.

Apr 13, 2016 9:31
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.