Try our conversational search powered by Generative AI!

After upgrade to Epi 9, my custom preview channels is missing



I haven't seen anything about breaking changes here, how can it just disappear

It's a simple DisplayChannel.

Any ideas in any direction here is welcome :)

May 12, 2016 10:42

What was the criteria to activate the display channel?
From which version you upgraded?

May 12, 2016 12:53

From EPi 8 ... 8.4 maybe it was.

The trigger is not the problem....the channel doesn't even show upp in the preview list dropdown.

May 12, 2016 13:31

It looks some structuremap issue, its failing to register your channel to DisplayChannelService. double check the initialization.

May 12, 2016 15:28

The initialization is running, I debugged it.

Could there be something new in web.config that is missing?

Took this from Alloy, it runs through init, but nothing appears in the UI...

	public class DisplayRegistryInitialization : IInitializableModule
		public void Initialize(InitializationEngine context)

			if (context.HostType == HostType.WebApplication)
				// Register Display Options
				var options = ServiceLocator.Current.GetInstance<DisplayOptions>();
					.Add("full", "/displayoptions/full", EPiServerApplication.ContentAreaTags.FullWidth, "", "epi-icon__layout--full")
					.Add("wide", "/displayoptions/wide", EPiServerApplication.ContentAreaTags.TwoThirdsWidth, "", "epi-icon__layout--two-thirds")
					.Add("narrow", "/displayoptions/narrow", EPiServerApplication.ContentAreaTags.OneThirdWidth, "", "epi-icon__layout--one-third");

		public void Preload(string[] parameters) { }

		public void Uninitialize(InitializationEngine context) { }
May 12, 2016 16:15

Those I took from Alloy were the resolutions, forget about them :)

But also in Alloy, there is this Mobile channel, which not seems to be visible either...anyone knows how that channel works in Alloy?

May 12, 2016 16:39

I have installed  a new fresh Epi 9 site (Alloy), and there the DisplayChannel works just fine.

I have compared it with my site, and the only thing that differs is the initializations, which has all moved from global asax to separate initializationModules. 

The resolution (channels) are working now in my site, I took them from Alloy 9. But the DisplayChannel, refuses to initialize.

I have also changed from 4.5 to target the 4.5.2 .net.

Any thoughts are welcome...

May 13, 2016 13:55

Try browsing the following urls for any clues



Ensure you are in the Administrators group and you have the following in your appSettings: 

    <add key="EPi.DebugView.Enabled" value="true" />
May 13, 2016 15:53

Ok added the appsetting

And tried:

 = 404

 = 404


So… not working you mean? I am member of administrators

May 13, 2016 16:15

Tried to "reset views" under my settings?

May 13, 2016 16:32


May 13, 2016 17:05

Ok thanks Tahir

Both urls renders lots of stuff

Anything in particurlar I shall look for?

Tried that now Daniel but nothing happens, except that all view are reset

However, I tested to add a few lines manuelly in global asax and then it works...but this is not the right way to do it :-/

// Manual registration, should not be like this... but I had to do something
			var service = ServiceLocator.Current.GetInstance<DisplayChannelService>();

	        service.RegisterDisplayMode(new DefaultDisplayMode("WidgetPreview")
		        ContextCondition = (r) => !r.Request.Browser.IsMobileDevice
May 13, 2016 17:32

Yes that was the way to do a initializationmodule

May 17, 2016 11:28

Wow, now after upgrading to 9.10.0, the preview channel is suddenly registered twice!

So...I removed my little manual register "fix" in global asax and then it is all back to normal again...weird isn't it!?

Epi has certainly been doing som experiments behind our backs here...

May 31, 2016 14:52

This was reported as a bug in EPiServer.CMS.Core 9.9.0 and fixed in 9.10.0.

Edited, Jun 21, 2016 15:31
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.