EpiServer CMS 9.8 on Azure does not allow site config without virtual directory


Hi All,

We deployed Alloy Tech on Azure following the guiddelines on:http://world.episerver.com/Documentation/Items/Developers-Guide/EPiServer-CMS/75/Deployment/Deployment-scenarios/Deploying-to-Azure-websites/ and http://marisks.net/2015/04/11/episerver-cms-site-as-azure-web-app/ in the new https://portal.azure.com.

When configuring the Site Settings it does nott allow me to set the Site URL to the primary domain http://xxxxxx.azurewebsites.net/. Instead I get a message stating that the site URL Must end with a virtual directory MyProjectName/

The site does work on the primary domain (without the virtual directory).

However, the CMS edit function does not work, it routes to a 404 page when trying to edit.

When setting up the project in Visual Studio 2015 I used IIS with a virtual directory 'MyProjectName' to run locally. It seems this might be the cause.

How can I fix this? My aim is to set the website URL to one without virtual directory and a working CMS.

Jun 01, 2016 9:08
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.