Dojo error and /episerver/cms only showing top menu



I'm struggling a lot with a dojo error and can't seem to find out what's the problem. Here's a screenshot of what's happening when I access /episerver/cms:

Dojo error in Chrome Developer tools

As you can see, there are two errors in some javascript files.

First error:

Dojo error source file

Second error:

Error in epi.js

And as you can see, no edit view:

No edit view

I'm thinking there are something wrong with my EPiServer packages / configuration.

Have anyone seen this before?


When inspecting the javascript, it fails when initializing this:


Edited, Aug 15, 2016 12:35

After a lot of debugging I eventually contacted EPiServer Developer Support and they found out what's wrong:

"We think we have found the cause for the issue. Apparently having the Visual Studio Web Accessibility Checker extension installed is causing this issue. I've created a bug report for it bug #CMS-4215 and sent it to our CMS developers and they will have a look into it. You can uninstall the extension and restart VS then the error does not occur again."

I tried uninstalling this Visual Studio extension and everything worked like a charm. Hope this will help someone in the future.

Edited, Aug 16, 2016 8:44

It should be enough to disable the browserlink functionality when working in the CMS UI, not to uninstall the entire extension.

Some background info on why this is happening.

The Accessibility Checker uses the Deque.Axe lib to perform actual work. This lib makes itself available as an anonymous AMD-module which works fine when it is required in that way. But unfortunatly this is not the case here, it is included in the the VS-browserlink javascript which is added as a script file and that breaks the module loader. Unfortunatly it is not much we can do to fix this from our end.

Aug 17, 2016 11:55

putting  <add key="vs:EnableBrowserLink" value="false"/>  in appSettings helped me to resolve issue. Hope, it may be usful for others.


Sep 04, 2016 15:57
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.