SaaS CMS has officially launched! Learn more now.

Thumbnails of uploaded images becomes 1x1 pixel

Vote:
 

Version: EpiServer CMS 10.0.1

Sometimes when various users upload images into the media/assett's pane the thumbnails doesn't seem to work but then when I look at the folder where the blobs are stored the thumbnail 1x1 pixel and very small in filesize:

Screen dump: https://www.dropbox.com/s/0ic0ecqc9hh870h/thumbnail_problem.jpg?dl=0

Any ideas on reason for this and how to fix it? 

e.g can one "re-generate" all thumbnails from within admin somewhere? 

#178787
Edited, May 22, 2017 15:35
Vote:
 

Have not seen thumbnails being generated as 1x1 before. 
There is a scheduled job for clearing all thumbnails thoug. It's called Clear Thumbnail Properties

#178813
May 23, 2017 11:46
Vote:
 

This sounded like the best solution so I ran the job (with status successful). But now all thumbnails are recreated as 1x1 pixel frown.

Is there a setting for this that can be tweaked in the db or web.config?

#178865
May 24, 2017 16:23
Vote:
 

Check your image model(s) for the ImageDescriptor attribute. If someone has made a property named "Thumbnail" this will override the default one

#179020
May 29, 2017 21:03
Vote:
 

Nice info thank you! I'm inheriting from the ImageData class and the Thumbnail property is NOT overridden.

[ImageDescriptor(Width = 48, Height = 48)]

public override Blob Thumbnail { getset; }  

But I wanted to test this. I overrode it in my class and changed the settings to be 128x128 instead and then ran the schedued job. And what do you know, it worked. Sure, they became 128x128 instead of 48x48 now but they all started showing up after that.

Weird, but I appreciat the replies that lead me here, thank you!

#179051
Edited, May 30, 2017 14:22
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.