SaaS CMS has officially launched! Learn more now.

Episerver Forms Metadata on form not working

Vote:
 

In version 4.6

I don't get "rendering metadata" working, is it just me or a bug?

http://world.episerver.com/documentation/developer-guides/forms/rendering-metadata-to-html-element/

No metadata is rendered on form-tag... 

#180998
Aug 04, 2017 15:22
Vote:
 

v4.6.1 works

#181064
Aug 08, 2017 8:50
Vote:
 

Allright, now i found it, I have an override of template in /views/shared/elementsblocks/formcontainerblock.ascx (and that one is really old!!) it didnt have the latest data-f-metadata="<%: Model.MetadataAttribute %>"

I had this to override Html.RenderElementsInStep(i, step.Elements); with Html.RenderElementsInStep(i, step.Elements, Model); to make EpiBootstrapArea work...

How are we supose to control if these templates are updated? it s a messy manual job...

#181078
Edited, Aug 08, 2017 11:19
Vote:
 

Who made that `EpiBootstrapArea` ??? Did I just read - "I was standing on thin ice and pointing shotgun at my boots.." ?!

I agree that this is a bit messy manual stuff. Had exactly the same thing but with datetime and recaptcha controls.. can't think of brilliant solution at the moment..

#181079
Aug 08, 2017 11:41
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.