Try our conversational search powered by Generative AI!

Problem running admin/edit on a different port (EPiServer CMS 10)



We're trying to run the edit/admin UI on a different port and have been following the guide here:

We're not interested in changing the UI "path" from the default (/EPiServer/CMS/), we just want to run it on a different port.

The guide says that to use a different port, we need to update the "uiUrl" property in our Web.config to include the full path and port which we've done, so now our uiUrl value is:

The guide then says to change a bunch of other paths in the config, for example from ~/EPiServer to ~/newuipath, but as we haven't changed the "path" part, we've left them all at their defaults so the only value we changed was the "uiUrl".
We can now access the CMS on port 8888 but as soon as we hit the edit or admin links, we get the "Incorrect link" error:
Incorrect link
The link you gave does not work, either because the page it points to has been deleted or moved.
If you clicked on a link, please inform the site’s webmaster that the link is faulty.

I've tried so many combinations of things in the Web.config based on what the guide says and can't get this to work.
Any help would be greatly appreciated!



Aug 25, 2017 13:05

Hej Anton,

Have you put your new url under admin/websites/Hosts, and make it "Edit" on TYPE?

Turn off "Incorrect link" error under admin/config tab/system settings/Error handling in EPiServer CMS change to OFF while testing...

If needed turn off customerrors and httperror in webconfig


Aug 25, 2017 13:53
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.