SaaS CMS has officially launched! Learn more now.

The Quick navigator not available when using different "Edit" domain

Vote:
 

Hi Episerver

We have a separate domain for when working in Episerver. So, episerver.website.com and www.website.com. 

We have set the cookie domain to just "webiste.com" in the forms authentication settings in web.config, and the ".EPiServerLogin" cookie is indeed saved with ".website.com" as domain. 

Still when we go to www.website.com we don't see the Quick navigator on the website, when we are logged into EPiServer on episerver.website.com.

Is there a workaround for this?

#182283
Sep 14, 2017 13:12
Vote:
 

Hi Denis, 

    <httpCookies domain=".gosso.se" />
    <authentication mode="Forms">
      <forms domain=".gosso.se" name=".EPiLogin_v2" loginUrl="Util/login.aspx" defaultUrl="~/" />
    </authentication>

had maybe to change name to "break thru"

Regards

#182334
Edited, Sep 15, 2017 13:08
Vote:
 

Thank you! That solved it. 

I only had this:

<authentication mode="Forms">
    <forms name=".EPiServerLogin" loginUrl="Util/login.aspx" timeout="120" defaultUrl="~/" domain="website.com" enableCrossAppRedirects="true" />
</authentication>


But I was missing this: 

<httpCookies domain="website.com" />


Adding the httpCookies settings worked.

#182337
Sep 15, 2017 13:41
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.