Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Unable to log in with windows membership provider


All of the sudden, I am unable to log in to my CMS site running in IIS Express on my local machine using my windows credentials. The confusing part is it is only happening on my machine. Using the exact same codebase on either of our other two developer's machines, I can log in. Similarly, they cannot log in with their credentials on my machine. I've replaced my whole solution from source control to verify I'm using the same files and deleted and re-downloaded all of the referenced packages. We then did a CRC comparison of the files to ensure everything was a match. I also deleted my temporary files to ensure it wasn't using an old version of anything. I tried creating my own login page in an attempt to get a more detailed error message, but I call Membership.ValidateUser and it simply returns false.

So I know my credentials are correct & valid and I know the configuration is correct because it all works on the other dev machines. What else could cause ValidateUser for the WindowsMembershipProvider to return false?

Here is my current membership & role configuration for the sake of completeness. They were originally using the multiplexing, but I changed it specifically to windows during troubleshooting with no change in results:

Jun 15, 2018 23:08

Hey Jesse,

If you create a new user in Windows and assign it Administrators access, it does work, doesn't it?


Jun 16, 2018 19:50

Hi Marija,

No that doesn't work either. I created a new local account and assigned it to the local administrators group and get the same result. Above I am using my domain account which is also a systems admin. Thanks for your reply.

Jun 18, 2018 15:16

This was a weird one. I think something in Windows was corrupted on my machine. We ruled out that it was anything to do with EPiServer project itself or even Visual Studio because I experienced the same problem in an older VS 2013 project as well.

I tried using windows authentication instead of forms authentication for the site and caused the browser to give me the error: "The trust relationship between this workstation and the primary domain failed." We tried updating my group policy and it failed with a similar error. So we re-joined my computer to the domain and the problem now appears to be fixed.

Jun 19, 2018 20:24

I have seen and have had that problem a lot eariler and only with Windows provider.

Since that provider is old and it is better to use the new one with Owin, I would receommend you to look into changing to that one.

I had so much problem with it a couple of years ago that we created initiation script that created us sql users.

Jun 20, 2018 7:24

There is something wrong with my code because when I publish my code to another server with a separate database r6300v2, the same problem occurs.

Nov 03, 2018 7:14

Are the servers on the same domain Berry?

Nov 05, 2018 7:01
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.