Try our conversational search powered by Generative AI!

Unable to create translation


My customer and I have been struggling with creating a translation for a specific page in EPiServer CMS 11.12

1. We open the page called "Products" in the sidebar. 

2. A yellow banner appears saying "This content is in English. It does not exist in français. Would you like to translate it now?"

3. We proceed to click the "Translate" button to the far right.

4. We click the "Create" button and then nothing happens except the button becomes disabled until we refresh the page.

When we hit 'Create' it sends a post request call to the following endpoint: https://*****.com/EPiServer/cms/Stores/contentdata/

With the following body: 

"name": "Products",
"parentLink": "112",
"contentTypeId": 51,
"properties": {},
"languageBranch": "fr",
"masterLanguageVersionId": "130_3890"

And we receive a 500 Internal Server Error in return.

I've tried using the debugger in local to see if any exception is thrown but no luck.

It seems to be an EPiServer specific issue. Is this a known issue in EPiServer and what exactly is going wrong? Is there any workaround or any way for me to pinpoint the issue?

Dec 17, 2019 15:04

Hi Flemming,

Have you tried this with Episerver language version gadgets?

Once you installed this add-ons please make sure the language editing is enabled for that language.

Edited, Dec 17, 2019 18:00

Flemming, have you looked at Episervers log files, to find the cause of the "500 Internal Server Error" ?
Hopefully Episerver is logging the details of this.

Your steps and POST request look fine until the Server Error.

Dec 17, 2019 18:53
Flemming - Dec 18, 2019 15:09
I checked the logs and it turns out that the type of content we were trying to create a translation for was disabled for the parent node. It's likely something that was disabled after creating the initial node in the past.

I enabled it and it is now working as intended. Thank you very much for your help.
Ravindra S. Rathore - Dec 18, 2019 15:12
Great to hear!! That is only related to Language Enabling :)
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.