Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Role x Has Permissions for Functions


Was wondering if there is a gadget, or existing view in the admin console that shows Role x has the following permissions.

I know I can navigate to the "Permissions for Fucntions" view, but this shows a giant containing all of the permissions available. 

I am looking for something that can show: The role Customer_Support_Analyst has the following permissions

started looking into implementing a gadget and discovered the table tblUserPermission which contains most of the information I am looking for, but does not contain the friednly description of the role.

For Instance, in the Permissions for functions screen you can see "Allows access to create catalog meta classes - (catalog:admin:meta:cls:mng:create)" but the tblUserPermission table only contains catalog:admin:meta:cls:mng:create.

May 09, 2019 17:02

That is actually a localization part, not the part of the data itself. 

May 09, 2019 17:37

Quan, thanks for your response.

So is it possible to fetch this information from Epi's internal Localization?

May 09, 2019 19:30

"admin/permissiontype/group/<permission group name, in your example, EpiCommerce>/permissions/<the permission without the : delimiter, in your example, catalogadminmetaclsmngcreate>" would give you the path to translation 

Edited, May 09, 2019 22:40

Ah Interesting.

I tried the following and i am receiving an empty string for each:

var permission = LocalizationService.Current.GetString("admin/permissiontype/group/epicommerce/permissions/catalogadminmetaclsmngcreate");
var permission = LocalizationService.Current.GetString("/admin/permissiontype/group/epicommerce/permissions/catalogadminmetaclsmngcreate");
var permission = LocalizationService.Current.GetString("/episerver/admin/permissiontype/group/epicommerce/permissions/catalogadminmetaclsmngcreate");
May 09, 2019 23:45

Sorry, it should have been groups, instead of group 

May 10, 2019 6:56

Thanks Quan Mai, this ticket can be closed!

The line that worked is:

var permission = LocalizationService.Current.GetString("/admin/permissiontype/groups/epicommerce/permissions/catalogadminmetaclsmngcreate")
May 10, 2019 20:59

Quan Mai,

I found a few instances where the translation returns ""

For instance, the below returns ""


was wondering if instead of epicommerce maybe epicms ?

May 21, 2019 16:21

It is the group name, in case of cms yes it should be epicms   (actually I'm not sure, check your db, you should see it there)

Edited, May 21, 2019 16:23

Quan Mai, do you know where in the DB I can find this? Which Table Name?

May 21, 2019 23:10

Look into tblUserPermission. I think it's EPiServerCMS 

May 22, 2019 8:47

Thanks Quan Mai!

May 22, 2019 19:57
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.