SaaS CMS has officially launched! Learn more now.

Date format for built-in properties in All Properties tab for a page

Vote:
 

Hello, 

I am trying to set a site to show built-in dates such as Published and Created dates for a page to show in Australian date format dd/mm/yy. This is when the user is logged in as an admin and showing all properties for a page in the Settings tab. 

I have tried setting the culture in the web.config to en-AU:

<globalization culture="en-AU" uiCulture="en" requestEncoding="utf-8" responseEncoding="utf-8" resourceProviderFactoryType="EPiServer.Framework.Localization.LocalizationServiceResourceProviderFactory, EPiServer.Framework.AspNet" />

I have also changed my browser's settings to use English(Australia) and ticked the Enable globalization and Detect language via browser's language preference in Admin | Config | System Configuration | System Settings. 

All these changes did not make any difference, the dates are still displaying in mm/dd/yy format. Any tips on how I can achieve this please? 

Cheers,

Raquel 

#205474
Jul 12, 2019 7:52
Vote:
 

Hi,

As per the comments under Remarks for Created Property and Saved Property those are maintained by the EPiServer infrastructure and we have no control over them.

Thanks,

Praful

#205475
Jul 12, 2019 8:46
Vote:
 

Hello Raquel

The formatting of date fields in Episerver edit mode is tied to the UI language, as you have already figured out. However, setting the system language to en-AU does not work, because only US English is supported out-of-the-box.

To quickly see which languages and locales are available:

  1. When inside edit mode, click your user name in the upper right corner, and then click "My Settings".
  2. The list of languages in the "Personal language" list box shows you which languages and locales are available.

You can probably cheat the system, by adding an empty translation XML with en-AU as its locale. Then you should be able to select this locale as the UI language, either as a user preference or in web.config.

If you try this out, please let me know how it works out for you.

#205488
Jul 14, 2019 8:31
Vote:
 

Hey guys,

The XML suggestion that Stefan points out is actually a neat trick, however you want to set your culture AND uiCulture to "en-AU" and it will work. I've just tested it.

i.e.:

<globalization culture="en-AU" uiCulture="en-AU" .....

#205491
Jul 15, 2019 6:34
Vote:
 

Yes, I also use this in my some of the projects and it works.

#205518
Jul 15, 2019 14:55
Vote:
 

Hi all,

Thanks for the replies. I have found out that this has been a bug that is now resolved in Episerver.CMS.UI version 11.19.1. 

Can't post links but should be in 

world.episerver.com/documentation/Release-Notes/ReleaseNote/?releaseNoteId=CMS-13585

We've upgraded to 11.20.0 and confirm that this is now resolved after setting globalization attributes.

<globalization culture="en-AU" uiCulture="en-AU"

Cheers,
Raquel

#205536
Jul 16, 2019 4:55
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.