SaaS CMS has officially launched! Learn more now.

Error message is not vanishing even the required field is filled.

Vote:
 

Hi,

This is happenning after upgrading Episerver to 11.6. While creating a page required field error message is still there even the field has valid value.

Thanks!

#206022
Aug 01, 2019 7:54
Vote:
 

On which field type are you using [Required] validation attribute? Or is this related to this issue. Can you please confirm that you are not following the steps similar to this issue?

https://world.episerver.com/forum/developer-forum/-Episerver-75-CMS/Thread-Container/2019/6/validation-of-property-with-emailaddressattribute-fails-on-empty-value

#206024
Aug 01, 2019 8:23
Vote:
 

Its string type, this issue is not related to the link you have provided. In earlier version, when the user filled with valid data in the property field, the required error message will automatically vanish. But after upgrading the Episerver to 11.4, this issue is happenning. The error message is still there in the page even having the valid property value. On clicking the error icon, it is vanishing.

#206025
Aug 01, 2019 8:34
Vote:
 

Then, in that case untill you click on error icon, is your auto save is woring? (can you see there saving message appears)

Then, autosave with updated time.

#206029
Aug 01, 2019 8:41
Vote:
 

Page is not saving

#206030
Aug 01, 2019 8:48
Vote:
 

I am getting a warning message in browser console, "OBSOLETE: epi/shell/_StatefulGetterSetterMixin Use dojo/Stateful custom setters/getters instead".

Does this issue is causing by dojo.js?

#206031
Aug 01, 2019 8:50
Vote:
 

Have you done any cusomization using dojo (in your project)?

#206032
Aug 01, 2019 8:52
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.