SaaS CMS has officially launched! Learn more now.

Changing name in URL doesn't affect URL in navigation

Vote:
 

Hi,

When I change the name in URL in edit mode and publish the page the URL is changed and I can view the page if I choose View on website. However, when I try to reach the page through the navigation of the site I'm directed to the old URL. 

The navigation gets the URL to the page with:
url = _urlResolver.GetUrl(contentReference, null, new VirtualPathArguments() { ContextMode = ContextMode.Default }); 

If I debug I can see that the URL fetched here is the old one. Does anyone know why I'm not getting the new URL here? 
Also, if I restart the website, the URL is updated with the new one.

Thanks

#230336
Nov 04, 2020 9:53
Vote:
 

Sounds like a caching problem. Do you have cache anywhere for the url resolving? 

#230338
Nov 04, 2020 9:55
Vote:
 

Yeah, it's a bug I stumbled upon myself earlier. I did a work around here until it's fixed

https://world.episerver.com/blogs/Daniel-Ovaska/Dates/2020/9/improved-url-caching-in-episerver/

#230349
Nov 04, 2020 11:27
Vote:
 

Found out that this was fixed in EPiServer.CMS.Core 11.20.0:

https://world.episerver.com/documentation/Release-Notes/ReleaseNote/?releaseNoteId=CMS-16555

#230442
Nov 05, 2020 14:11
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.