SaaS CMS has officially launched! Learn more now.

Episerver Browser requirements for editing

Vote:
 

Hi,

We have the following Episerver CMS:

Version 6 R2

Version 7.5

Version 9.7

Even though the Browser requirements in this link tell us what Browsers are supported for the CMS all CMS are working fine in the latest versions of IE11, FireFox and Ege

https://world.episerver.com/documentation/Items/System-Requirements/system-requirements---episerver/?p=203157

Chrome has been an issue with 7.5 and 9.7 for sometime now YET it still works with 6R2.

Can you tell me if newer versions will stop working for any of these CMS.

Obviously version 6 R2 is not an easy upgrade to the latest 11. Even our version of 7.5 which uses Commerce can not be upgraded to 11 (Episerver support have said told us this due to the complexity of the CMS and Commerce).

Thanks

#216390
Feb 05, 2020 11:14
Vote:
 

We never know, it's Google who can make change to Chrome and break things in older versions. If the issue is severe enough we might provide a fix, but with 6R2 and 7.5 are likely out of luck.

Commerce 7.5 can be upgraded to latest version, but that is of course a major work. there are different solutions to tackle that problem, depends on your content strategy and budget.

#216392
Feb 05, 2020 11:41
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.