Try our conversational search powered by Generative AI!

After updating Episerver Find from version 12 to version 13, I cannot update the field in the index by id


Good afternoon. Faced the problem of updating the field in the find index after upgrading episerver find to version 13. It worked like that. There is a ContentData object for which is added to UnifiedSearch. An id is defined for it using `.IdIs (x => DocumentId.Create (x.Id))`. `IdAttribute` is added to the id field.Now when I try to update some field for this content, I get an error that the content does not exist in find. For this i use:

var id = SearchClient.Instance.Conventions.IdConvention.GetId({contentId});

SearchClient.Instance.Update<T>(id).Field(x => x.SomeField(), d.SomeField()).Execute();


"RemoteTransportException[Index][indices:data/write/update]]; nested: DocumentMissingException[[index][1] [SomeType][SomeId]: document missing]; "

This code worked fine on the previous version of episerver find (12.7.1). Help me please!

Mar 23, 2020 8:35
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.