Try our conversational search powered by Generative AI!

CMS-11 - Server error in '/' application. The resource cannot be found


I recently installed the CMS 11.0 extension in my Visual Studio and am trying to setup a demo site with Alloy. I have attached the .mdf file to my SQL Server and updated the connection string to: <add name="EPiServerDB" connectionString="Data Source=.\SQLEXPRESS;Initial Catalog=EPIDB;Integrated Security=True;MultipleActiveResultSets=True;Connect Timeout=60" providerName="System.Data.SqlClient" />

I have given full permissions to "Everyone" in the folder where I keep the source code in E drive. However, when I try to run the code it throws an error like :

Server error in '/' application
The resource cannot be found.
Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.
Requested URL: /

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.8.4330.0

Please let me know where I could be going wrong.

Dec 24, 2021 3:09

Hi Anant,

Are you configuring the Alloy site or EmptySite?

If you are configuring the EmptySite then try /episerver after your site URL because Emptysite doesn't have any start page

Like - http://localhost:45454/episerver

Dec 24, 2021 12:44

Hi Ravindra,

Thanks for replying but I have tried with both the Empty Site and the Alloy site template. I get the same error in either case. As you mentioned, the Empty site gicing this error is fine but the Alloy site should give me a registration page which I didn't get.

Any suggestions?

P.S.-> The connection string I specified above is for the Alloy site. Is it fine to use windows authenticaton for Alloy?

Dec 25, 2021 8:07

One quick question - Are you running the Alloy site using ctrl+F5 or by hosting it in IIS?

Dec 27, 2021 8:25

Ctrl+ F5.

And it's working for my Empty Site. I am able add pages and properties to the new site. It's just the Alloy template I can't figure out.

Dec 27, 2021 9:04

If the empty site is working fine then Alloy should also work.

Lets try once again and don't update anything after project creation. Like - Connection string etc...

Follow these steps- 

  1. Create a new project.
  2. Select Alloy template.
  3. Once the project created successfully. Hit F5
Dec 27, 2021 9:11

Hi Anant,

When you try to run your site with the failing setup, do you get something to error log? By default in App_Data\EPiServerErrors.log

Dec 30, 2021 19:59
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.