Google Analytics Gadget doesn't work for non-admin user

Vote:
 

We’ve implemented and set up th GA in our websites. The connecting to the GA account is successfully done and I (with Admin rights) can see the GA data through Gadget.

But when the other users want to use the GA gadget they are getting an error and not data is showing.

 

Further investigation shows that they’re getting access permission errors -403 for the below url in the browser

 

..../EPiServer/EPiServer.GoogleAnalytics/Context/Index?preferredNamespace=EPiServer.GoogleAnalytics.Controllers&gadgetId=73d9bcda-8c96-4c77-bb2d-5b5da47d2c4e&dojo.preventCache=1629703940900

 

 

 

 is there any specific permission or setting  in web.config requires to see the data from GA gadget and how can we enable that for the non-admin user if it is limited to them only?

Our authentication is AD-Integrated.

Thanks in advance

#261089
Aug 25, 2021 4:06
Vote:
 

Hi Vahid

The Google Analytics add-on is not based on "Permissions for Functions", but on named groups.

The add-on is available for users in these groups:

  • GoogleAnalyticsAdministrators
  • GoogleAnalyticsReaders
  • Administrators
  • WebAdmins

Ensure that the AD federation is configured to support those first two roles. And ensure that relevant users are assigned those roles when logging into Episerver.

#261242
Aug 28, 2021 16:12
Vote:
 

Thanks Stefan

Adding GoogleAnalyticsReaders and GoogleAnalyticsAdministrators fixed the issue. however addiung GoogleAnalyticsReaders  would be enough

#261712
Sep 05, 2021 22:50
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.