Try our conversational search powered by Generative AI!

How change url to commerce manager login?



I have moved our production site to a test enviroment. Database was setup by restoring production dbs. CMS part of site works fine. My problem is, that I cannot get the link to commerce manager right, the iframe loaded in the login page (and also the login request), goes to our production site. Checking the EPiServer.Business.Commerce.UI.Admin.SitePlugin.CommerceManager which generates the commerce manager url, it seems like this setting is read from dynamic data.

Have done this:
- used fiddler to verify my login request (and login form) are from my production site
- updated connectionstrings to go to testdb
- checked appsetting CommerceManagerLink - set to localhost:17001
- turned off local CommerceManagerSite. Login page is still shown, which means my content is not from this site
- turned on local commercemanager site, gone to the root page and logged in with my test credentials. Works fine.
- searched c:\episerver for any file containing our production url or production ip. nothing. Searched registry as well.


Sorry for this silly question, but I cannot find a way to edit this setting anywhere...

Thanks for your input!
/ Markus

Oct 03, 2012 15:48

Found it tblBigTable, String01 for StoreName EPiServer.Business.Commerce.CommerceSettings. Updated this manually and worked fine :-)
Surprised that this wasn't an ordinay setting in a config file?

/ Markus


Oct 03, 2012 16:15


This is a setting under the Commerce-->Settings.  You should be able to set it there and not bother with updating the value directly in the database.




Oct 17, 2012 21:13

Hi, Tim!

What a cooincidence - just a few hours before your post I got tired of seeing an error page when clicking on Settings (missing masterpage). Fixed this and saw the easy way to change settings.

Thanks for you help!

Oct 18, 2012 11:20
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.