Error creating new Commerce site



I tried to create a new Commerce solution using the latest Visual studio extension and nuget packages.
Althought creating a new Commerce solution is pretty straight forward, I end up with the following error message when starting the site (both commerce manager and frontend site)

There are incomplete migration steps. The site can be in unstable state. Please navigate to front-end site and complete remaining migration steps, then restart Commerce Manager site. If you see this message on the front-end site, it means no Catalog Content models (decorated with the CatalogContentType attribute) were found. Add a Catalog Content type, or set the appSetting 'episerver:SkipCatalogContentModelCheck' to true to bypass this check. Warning! Bypassing this  check in the Commerce Manager site or other application which does not have the content model types available could lead to data loss!

I followed all the steps from the documentation

Visual Studio 2013
EPiServer CMS Visual Studio Extension
EPiServer.CMS 9.2.0
EPiServer.Commerce 9.0.0

I'm not able to log in to the site or commerce manager because of this error.
Is it safe to set 'episerver:SkipCatalogContentModelCheck' to true since it can cause data loss?
Or did I forget something?

Oct 22, 2015 10:09


What you should do is to create some content model types in front-end site, build it, start the site for the migration steps to complete, then restart the commerce manager site.

episerver:SkipCatalogContentModelCheck should not be added to Commerce Manager site.



Oct 22, 2015 10:44

Thanks Quan!

I created a dummy ProductContent type.

        DisplayName = "DummyProduct", 
        GUID = "4965d65c-9415-43dd-ad9c-3d4d080fd27d", 
        Description = "")]
public class DummyProduct : ProductContent

After that I was able to start the migration.

although I think it's kind of weird to create a dummy content type before starting the migration, it solves my problem for now.


Oct 22, 2015 11:15


i am also using same visual studio extension ,if i run the Alloy site(webform) then i get this error 

Operation could destabilize the runtime

Nov 25, 2015 14:31
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.