SaaS CMS has officially launched! Learn more now.

Catalogs.js not found error after upgrade to 8.11



After upgrade to commerce 8.11 the commerce catalogue is missing and i get this error



anybody have idea?



Apr 27, 2015 11:25

It's quite clear that you have a faulty module registration. It should belong to Commerce module instead. What do you have in your protectedModules section in web.config?



Apr 27, 2015 12:00

thank you for your reply

<protectedModules rootPath="~/SPSM/manage/">
<add name="AddOn.Favorites"></add>
<add name="EPiServerCommon" resourcePath="~/EPiServerCommon/">
<add assembly="EPiServer.Common.Gadgets" />
<add assembly="EPiServer.Common.Criteria" />
<add name="Commerce">
<add assembly="EPiServer.Business.Commerce" />
<add assembly="EPiServer.Commerce.UI" />
<add name="EPiServer.Commerce.Shell" resourcePath="{rootpath}/Commerce/Shell" />
<add name="Shell" />
<add name="CMS" />
<add name="Find">
<add assembly="EPiServer.Find.Framework" />
<add assembly="EPiServer.Find.UI" />
<add assembly="EPiServer.Find.Cms" />

Apr 27, 2015 12:15

Have you run the Move-EPiServerProtectedModules cmdlet in the package manager console?

Apr 27, 2015 13:18

No, i haven´t should i?

Apr 27, 2015 13:27

Yes. It has been around for a long time but since Commerce 8.11 it is a requirement. There is a note in the package readme but maybe it didn't pop up as it should.

Apr 27, 2015 13:29

ok, but now im getting other error

Unable to find a module by assembly 'EPiServer.Commerce.AddOns.Manager, Version=2.0.926.0, Culture=neutral, PublicKeyToken=null'

Parameter name: moduleAssembly

i can see it is located under \modules\_protected\EPiServer.Commerce.AddOns.Manager

but somehow is not getting loaded.. did i miss something?

Apr 27, 2015 14:33

It could be an assembly binding issue that is hidden. Anyway, it looks like you still have the old site-owner addon. Please try to install the EPiServer.Commerce.UI.ManagerIntegration nuget package and see if that works. 

Apr 27, 2015 14:43

ok i got different error now after running managerintegration

Unable to find a module by assembly 'EPiServer.Commerce.Shell.ManagerIntegration, Version=, Culture=neutral, PublicKeyToken=8fe83dea738b45b7' Parameter name: moduleAssembly

same same but different :S

Apr 27, 2015 15:53

Another customer had same issue with EPiServer.Commerce.Shell.ManagerIntegration and the solution was to run Move-EPiServerProtectedModules



Apr 27, 2015 15:55

no lyck..

I have run the Move-EPiServerProtectedModules

it added the line i web.config and also deleted the modules folder from appdata 

still getting this error when trying to log in to edti mode

Apr 27, 2015 17:59

where should this file be located? 

I have it in my bin already, when i delete it from my bin i can enter online center but can´t do anything and get 
"NetworkError: 404 File not found - http://spsm.local/hittalaromedel/SPSM/manage/Shell/"

Apr 27, 2015 18:07

The EPiServer.Commerce.AddOns.Manager file is no longer needed. It is replaced by the EPiServer.Commerce.Shell.ManagerIntegration which should be in your bin-folder after you installed the package and recompiled. You should also have another entry in your protectedModules config. How does your virtual path provider configuration look (section episerver.framework / EPiServerFramework.config)?

Apr 27, 2015 19:51

aha ok, well what happends when i install this package is im getting the error:

"Unable to find a module by assembly 'EPiServer.Commerce.Shell.ManagerIntegration, Version="

Which entrys should i have in my modules config and EPiServerFramework.config?

Maybe thats the missing part

Apr 27, 2015 20:58

I think your protectedModules section looked correct, but you should have another entry now that you installed the ManagerIntegrationPackage:

<add name="EPiServer.Commerce.Shell.ManagerIntegration" resourcePath="{rootpath}/Commerce/Manager" />

Your virtual path configuration shouldn't contain any references to commerce, but something similar to:

<add name="ProtectedAddons" virtualPath="~/EPiServer/" physicalPath="modules\_protected" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider, EPiServer.Framework" />

Note: The virtualPath of the VPP should match what you have as rootPath for protectedModules.

Edited, Apr 28, 2015 7:15


That helped alot.

add name="ProtectedAddons" virtualPath="~/EPiServer/" physicalPath="modules\_protected" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider, EPiServer.Framework" was not quite right in my solution... physicalPath="[appdata]\_protected" after changing it to physicalPath="modules\_protected" ;it works better!

Apr 28, 2015 9:29
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.