Try our conversational search powered by Generative AI!

Drag and drop in catalog ui broken after upgrade to Epi 10



We are upgrading our project to Epi CMS and Commerce 10. Everything is working fine except for the drag-and-drop functionality in the catalog. When dropping the product at the new location Epi gives the message "One or more of the objects have a content type that is not allowed on the destination". When inspecting the page in the browser we get a javascript error in a dojo:

Uncaught TypeError: Cannot read property 'getCurrentContext' of undefined 

As you can see, not much information dorm that one.

Anyone else experiencing this problem?

Dec 16, 2016 15:33


Some screenshots of the problem would be very helpful for us.



Dec 19, 2016 15:54


We got the same error after upgrading to EPi CMS & Commerce 10.


Thanks in advance!

Dec 19, 2016 16:38

How do you drag and drop the products? I just tried to drag a product from catalog content list (the list in the center) to the catalog tree (the left panel), and it works just fine ...

Dec 19, 2016 17:06

That is exactly what we're trying to do but get that error message.

This feature worked fine before the upgrade.

Any suggestions what could cause this ?

Dec 19, 2016 17:10

What version of the EPiServer.CMS.UI package do you have installed?

Dec 20, 2016 7:20

@Magnus: We have the EPiServer.CMS.UI 10.2.0 installed

Dec 20, 2016 9:37

We have discovered an incompatibility between the commerce UI and EPiServer.CMS.UI 10.2. Please use EPiServer.CMS.UI 10.1.1 for now. The soon-to-be-released Commerce 10.2 will enforce this version cap until we can get compatible versions out.

Dec 21, 2016 14:44

That did the trick. Works now!

Thanks a lot Magnus!

Dec 21, 2016 22:44
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.