SaaS CMS has officially launched! Learn more now.

Create Payment in Commerce Manager

Vote:
 

Hi Support,

We are using two custom payment gateway in our project and working fine for the front end but facing issues in the create payment option in the commerce manager. We are getting "Object reference not set to an instance of an object." error when clicking on the "Create Payment".

Notice that if the payment method (both added by us) is turned off in payment method table, then at back end the create payment option opens
with a popup but with the blank drop-down for payment (for obvious reason) but the moment we are activating the payment gateway it is throwing error.

So of course, we have to do something to make the create payment option available for the commerce manager. Any solution regards to this will be appreciated.

#174212
Jan 21, 2017 5:13
Vote:
 

What version are you using? Which payment gateways do you have configured?

For me it seems the assembly contains one or more payment gateways is missing from bin of Commerce Manager. Do you have anything in log?

#174214
Jan 21, 2017 9:38
Vote:
 

Hi

Thanks for the response.

We are using OXXCommerce as a template base for our website which we have uprgarded to the latest version 10.2.2. We have used the following Payment Gateways:

- Pay By Phone (Generic)
- PayPal (Custom)
- Alipay

For Paypal we have added the sdk dll in commerce manager too. Alipay doesn't have a dll which we can add to the commerce manager. Even if we deactivated both (paypal and alipay), the commerce manager is not showing pay by phone option as mentioned in the different post.

Another thing we have noticed that when we click on "complete return", the popup is coming with the values though throwing error when we select the option Alipay or Paypal as an option to refund.

http://world.episerver.com/forum/developer-forum/EPiServer-Commerce/Thread-Container/2015/2/ysod-when-trying-to-edit-purchase-order-in-commerce-manager/

Error Log in Commerce Manager:


2017-01-20 14:53:08,226 [8] ERROR ASP.global_asax - Backend encountered unhandled error.
System.NullReferenceException: Object reference not set to an instance of an object.
at Mediachase.Commerce.Manager.Apps.Order.Modules.PaymentMethodSelectControl.BindMetaForm()
at Mediachase.Commerce.Manager.Apps.Order.Modules.PaymentMethodSelectControl.CreateChildControls()
at System.Web.UI.Control.EnsureChildControls()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
System.NullReferenceException: Object reference not set to an instance of an object.
at Mediachase.Commerce.Manager.Apps.Order.Modules.PaymentMethodSelectControl.BindMetaForm()
at Mediachase.Commerce.Manager.Apps.Order.Modules.PaymentMethodSelectControl.CreateChildControls()
at System.Web.UI.Control.EnsureChildControls()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Control.PreRenderRecursiveInternal()
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

#174216
Jan 21, 2017 10:14
Vote:
 

Hi,

Does this happen before the upgrade? As 10.2.2 is very new so I suppose you upgraded recently?

One possible issue with Commerce Manager during upgrade and deployment is that the Apps folder might not be updated/deployed completely. One or more files might be missing/corrupted. Can you compare the Apps folder of your site to a freshly installed 10.2.2 Commerce Manager to make sure all files match?

/Q

#174222
Jan 21, 2017 23:39
Vote:
 

I just checked and confirmed that the it is not working on the previous version either. In regards to more insights, we have installed oxxcommerce with 9.2.7 version of epi and then used PayPal and Ali pay payment gateway. We have updated our site directly from 9.2.7 to 10.2.2.

One thing we have noticed when we are deactivating alipay from paymentmethod table, the create payment pop up under Orders>Payments tab is correctly showing. However, on selecting the PayPal option it's throwing an error. When activating the alipay payment method, even opening the create payment pop up is throwing an error.

#174223
Jan 22, 2017 8:06
Vote:
 

Can you try with Quicksilver and or an empty Commerce site to see if it works for you. OxxCommerce is not offically supported by us and hasn't been updated in 2 years so it might not work as expected

#174224
Jan 22, 2017 10:17
Vote:
 

The situation is quite complicated and we have gone too far with this project now can you tell us one thing that what is happening in 

Mediachase.Commerce.Manager.Apps.Order.Modules.PaymentMethodSelectControl.PaymentMethodList_SelectedIndexChanged

Event.

Because what I am getting in this event something is not matching for PayPal.

Now I need to recognize what and if it is possible to work with database then it will be more favourable  .

Please help to recognize.

#174543
Jan 30, 2017 5:32
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.