Try our conversational search powered by Generative AI!

EPiServer Commerce 10 with issue unauthorized


Hi everyone,

I'm developing the addon based on the EPiServer commerce & EPiServer ServiceApi.

my addon is running well on EPiServer commerce 9 & below but it is not working after the update to version 10 with EPiServer ServiceApi version 3.0 or 3.0.1

I debugged & found that it got token well & sent the request GET with token to the Commerce site to get all catalogs but received message "Internal Server error" or "Unauthorized".

Really, I also tried many times to fixed but have not found the cause yet.

So could anyone know & saw this issue then give me any suggestion ?

Thanks so much

Apr 10, 2017 12:33


Can you post full stacktrace of the error? Does the problem only happen with that API (get all catalogs), or on all APIs?

Apr 10, 2017 13:55

Hi Quan,

thank for your reply

{StatusCode: 500, ReasonPhrase: 'Internal Server Error', Version: 1.1, Content: System.Net.Http.StreamContent, Headers:
Pragma: no-cache
Cache-Control: no-cache
Date: Tue, 11 Apr 2017 02:20:08 GMT
Server: Microsoft-IIS/10.0
X-AspNet-Version: 4.0.30319
X-Powered-By: ASP.NET
Content-Length: 1397
Content-Type: application/json; charset=utf-8
Expires: -1

that is error message returned from the request GET.

this request GET is sent to my addon inside the Commerce Site but there is problem with authentication via attached token therefore this request is returned the error as above without jumping to my API to get all catalog.

This problem is occurring with all my APIs, but them are running well with EPi older versions(7,8,9).

Thanks so much,

Apr 11, 2017 4:31

This is gonna need a support ticket. Anything from the log? 

Apr 11, 2017 11:04

it very strange, below are my email & skype, if possible we can exchange my sample code then you can easy to help me to detech where is problem ?

on other hand, I also tried with the QuickSilver source code by installing EPiServer.ServiceApi but the same.



Edited, Apr 11, 2017 12:20

Hi, no, I can't do that, you'll have to contact our developer support service. I am only allowed to help if the problem can be answered/fixed in a reasonable amount of time. Other than that it should be via our official channel. The developer support team can then escalate the problem to us (development team), but we can't take actions until then. 

Apr 11, 2017 12:24


can you give me the contact of the Developer suport service ?


Apr 11, 2017 12:27

The contact can be found here:

Apr 11, 2017 12:28

Hi Trung,

I did offline chat with your colleague (Bien Tran) and this issue was resolved.

You're using old Quicksilver and upgraded to latest core and service api.

The issue was fixed by sending correct token:

And also did work around following this thread:


/Son Do

Edited, Apr 13, 2017 12:58
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.