Writing to ApplicationLog when saving catalog data



When I write to the catalog (Either by using ICatalogService or IContentRepository), I get a lot of entries in the ApplicationLog-table in the Commerce-database.

I tried to remove the  from ecf.catalog.config, but it didn't seem to help.

Since this affects the performance, and since I use other logging mechanisms when writing to the catalog, are there any way to remove this?

Aug 29, 2017 8:52

The logging is used for auditing, and also for incremental index, so we don't want it to be disabled. You might still be able to do (haven't tried myself), but it can be very "hacky" doing so.

Aug 29, 2017 9:18

Thanks Quan,

As you understand, I try to tune the catalogimport as much as possible. :)

I see that when I import a lot of data through the import, I get a lot of locks, since saving the catalog is using transactions. If the batches are too big, this will lock the database and the users will get lock-errors.

Are there any ways to disable the transactions while importing? And are other parts of the commerce api reading optimistic with (with(nolock) keyword) or pessimistic, so we don't get the lock-errors?

Aug 29, 2017 10:50

There is no way to disable transaction either :). There are parts of system which are not supposed to be "customized".

Keep in mind that if you have problems with import performance, you can always contact our developer support service, or the expert services for assistance. 

Aug 29, 2017 10:55
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.