SaaS CMS has officially launched! Learn more now.

Commerce 11: Issue with Solr search configuration.



I have tried to replace Lucense search to Solr search in the commerce application. For that, I followed the below guide from EPiServer.

In the step 2 (Install the Solr Application) I have completed the following first two points (1 & 2), but I faced issues on the 3 and 4th points:

  1. Download the Solr installation files (version 3.5) from Apache Solr.
  2. From this  package, copy  apache*.war into [Tomcat installation path]/webapps path].
  3. Download the version of the EPiServer.Commerce.Solr35SearchProvider NuGet package that matches your Commerce site.
  4. Place the solr folder in the Tomcat installation directory.

The problem is, after downloading the package (EPiServer.Commerce.Solr35SearchProvider  version 11.2.0) there is no "SOLR" folder inside. Due to this issue unable to proceed with "Place the solr folder in the Tomcat installation directory"  and  "Edit the schema file in the Tomcat instance at solr/catalog/conf/schema.xml".

Kindly helping on this to complete the configuration setup.

Also I tried using default schema from solr and the solr admin panel is working,  but EpiServer commerce index throws the error.

HTTP Status 404 - /solr/catalog/update

type Status report

message /solr/catalog/update

description The requested resource is not available.

Apache Tomcat/7.0.81

Sep 15, 2017 12:00

I found some workarround for this problem. In the solr.xml I Just replaced the default cores name to "catalog" and it is working now.

<cores adminPath="/admin/cores" defaultCoreName="catalog">
<core name="catalog" instanceDir="." />


Sep 15, 2017 14:35

That's ok for solr.xml, but where you get the solr folder to place in the Tomcat installation directory..

Mar 14, 2018 6:42
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.