SaaS CMS has officially launched! Learn more now.

Could not load Mediachase.Commerce.Marketing.Validators.dll of version 13 after upgrade

Vote:
 

After upgrading to latest versions of EPiServer packages, I am getting error -- System.TypeLoadException: Could not load type 'Mediachase.Commerce.Marketing.IPromotionEntryPopulate' from assembly 'Mediachase.Commerce, Version=13.0.0.0.
Mediachase.Commerce.Marketing.Validators.dll is present in EPiServer.Commerce.Core.12.16.0\lib\net461 but not in folder
EPiServer.Commerce.Core.13.0.0\lib\net461

#202644
Mar 28, 2019 10:48
Vote:
 

Mediachase.Commerce.Marketing.Validators.dll is removed from Commerce 13. I'm not sure why the nuget update does not remove it for you - it should have done it automatically

#202646
Mar 28, 2019 10:58
Vote:
 

@Quan Mai: Is the backend/edit mode user validated automatically in frontend? 

#202688
Mar 29, 2019 3:38
Vote:
 

Not sure I understand your question. Can you elaborate ?

#202690
Mar 29, 2019 7:08
Vote:
 

@Quan Mai Sorry, I am supposed to post that second question in another post and I posted in another thread.

#202694
Mar 29, 2019 7:41
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.