SaaS CMS has officially launched! Learn more now.

Getting 404 trying to get /episerverapi/commerce/catalogs



I started a new alloy project added the Service API and Commerce package, updated Startup.cs to use 

app.UseServiceApiIdentityTokenAuthorization<ApplicationUserManager<ApplicationUser>, ApplicationUser>();

Just to make sure I have added UserGroup "WebAdmin" to the Episerver service api Read/Write permission in the Admin.

I can get the token but 404 on 


tried both adding and removing

<add key="episerver:serviceapi:maphttpattributeroutes" value="false" />
Edited, Jan 23, 2020 14:48

Just to be sure, did you install Episerver.ServiceAPI.Commerce?

Jan 27, 2020 8:54

Yes, I did install Episerver.ServiceAPI.Commerce.

Jan 28, 2020 9:47
<add key="episerver:serviceapi:maphttpattributeroutes" value="false" />

this should be true, not false.

Jan 28, 2020 13:07

I changed the value to true. Still no luck.

I get:

Server Error in '/' Application.

The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly. 

Requested URL: /episerverapi/commerce/catalogs
Jan 28, 2020 14:07

Does it work with other resources? or all resources are not working?

Jan 28, 2020 14:16

all not working. I installed Episerver.Commerce, do I need something more?

Edited, Jan 28, 2020 14:27

Update: I created a new project again and added Episerver.Commerce.UI.ManagerIntegration. With that it worked. So I thought that was the missing element and added the package to the old project but it still didn't work.

Not sure if I should consider this as solved???

Edited, Jan 29, 2020 12:48

That should have nothing to do with ServiceApi

Jan 29, 2020 13:59

I don't think I did anything else than that difference. Since it works for now, I think I'll set it as solved unless I find myself in same situation in the future.

Or if there is something I should consider to make that work, please let me know :).


Edited, Jan 29, 2020 14:34
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.