Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Friendly Url after upgrade

Vote:
 
Hi. When upgrading from pre 4.60 to 4.60 or newer, none of the pages has the friendly url's set. Is there any "easy" way to fix this, so that friendly urls are generated for all pages (and perhaps internal links)? Anyone tried something like this? I can imagine a script that loops through the page structure, setting the friendly url as the page name, would do the trick. Any method in the API for handling this? Thanks. Frank :)
#12891
Jan 08, 2007 11:02
Vote:
 
Enkelt eksempel: foreach (PageData page in pages) { page.URLSegment = page.PageName Global.EPDataFactory.Save(page, EPiServer.DataAccess.SaveAction.Publish); } Her må du nok modifisere litt og sørge for at PageName blir bla. "url-vennlig"
#15044
Jan 08, 2007 12:49
Vote:
 
Ask support for a util that does this for you. :-) /Steve
#15045
Jan 08, 2007 17:12
Vote:
 
I wrote an admin mode plugin that allows you to update friendly URLs. I is very configurable and does things like character replacement, character stripping, creating segment from different properties, setting segment maximum lengths, selectable tree branch, and supports test runs. It is not complete as it doesn't support multi-lingual sites yet (still working on that part, almost there). If you want a copy I have made a compiled version of it available at the following URL http://www.box.net/public/static/ivshftca08.zip. To install it just unzip the contents of the zip file to your website and a new option will be available under the admin mode tools. Make sure you test it in a safe environment before trying in a production environment (goes without saying really). I have used this on some of our production sites without issue. Cheers, Jeremy.
#15046
Jan 09, 2007 2:09
Vote:
 
Thank you very much, Jeremy. Just what I was looking for. Frank :)
#15047
Jan 09, 2007 8:21
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.